Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0011199 [DCSS] Bug Report minor have not tried 2017-08-25 15:38 2017-11-19 16:46
Reporter Shtopit View Status public  
Assigned To advil
Priority normal Resolution done  
Status resolved   Product Branch 0.20 ancient branch
Summary 0011199: Ghoul regen blocked, reason unknown (unseen monster?)
Description I'm outside the entrance of the swamp. I wait, but I don't get healed. I guess that there is some monster in hiding somewhere, activating low regen for ghoul? I think you shouldn't be able to rest in such conditions. See image for vault info. Tavern discussion https://crawl.develz.org/tavern/viewtopic.php?f=17&t=24178&p=319694#p319694 [^]
Additional Information
Tags No tags attached.
Attached Files png file icon 2017-08-25 (2).png [^] (16,230 bytes) 2017-08-25 15:38

- Relationships
has duplicate 0011197resolvedadvil Ghouls don't regenerate near friendly monsters 

-  Notes
(0031793)
Shtopit (reporter)
2017-08-25 23:55

Possibly related: https://crawl.develz.org/mantis/view.php?id=11112 [^]
(0031920)
Shtopit (reporter)
2017-11-16 10:59

The issue also is there with naga with no regen with enemy in sight. In Swamp I spent some turns waiting (5) without any messages or regeneration actually happening, because of a submerged worm.
(0031923)
advil (administrator)
2017-11-19 16:46

Thanks for the report, I actually merged a PR fixing this a while ago in trunk and apparently just forgot to close this issue: https://github.com/crawl/crawl/commit/90186ba4bab6 [^]

- Issue History
Date Modified Username Field Change
2017-08-25 15:38 Shtopit New Issue
2017-08-25 15:38 Shtopit File Added: 2017-08-25 (2).png
2017-08-25 23:55 Shtopit Note Added: 0031793
2017-11-16 10:59 Shtopit Note Added: 0031920
2017-11-19 16:46 advil Note Added: 0031923
2017-11-19 16:46 advil Status new => resolved
2017-11-19 16:46 advil Fixed in Branch => 0.21 development branch
2017-11-19 16:46 advil Resolution open => done
2017-11-19 16:46 advil Assigned To => advil
2017-11-19 16:47 advil Relationship added has duplicate 0011197


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker