Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0001116 [DCSS] Bug Report minor have not tried 2010-03-19 19:01 2015-06-28 21:40
Reporter angrykoopa View Status public  
Assigned To MarvinPA
Priority normal Resolution done  
Status resolved   Product Branch 0.6 ancient branch
Summary 0001116: Luring ancient champion to a different floor and killing it doesn't open up hole in iron wall
Description Not sure if this is meant to be, but it seemed like a bug.
Additional Information
Tags No tags attached.
Attached Files

- Relationships
has duplicate 0005088closed Ancient Champion Vault Bug 

-  Notes
(0003507)
due (developer)
2010-03-19 23:32

A limitation rather than a bug, and currently a difficult one to overcome. Solution: do not lure them down the stairs, it will not work well for you. The other option is to switch to a system similar to that of the Royal Jelly, but this is not for 0.6 consumption, sorry!
(0003513)
OG17 (reporter)
2010-03-20 04:37

Couldn't the thing be unable to use stairs and shafts?
(0003514)
due (developer)
2010-03-20 07:24

That would be immensely more complicated and honestly not worth it. :)
(0003520)
angrykoopa (reporter)
2010-03-20 15:26

really now? idk much about code, but couldn't you just give them the zombie/ghost/skeleton flag to force them to stay on that floor?
(0003525)
due (developer)
2010-03-21 01:43

Giving them the zombie flag would probably require adding a new flag type, access to that flag from the Lua side of things (for the vault definitions), and changing the hook types for stair changes to cope with the new flag type, etc. All of that would require new code, recompilation, etc, while just doing it in Lua would only require new Lua code, as the monster-death-code framework is already in place for the Royal Jelly.
(0024133)
Grandiloquent Gentleman (reporter)
2013-10-02 13:58

Ancient champions have changed since this bug. Is it still relavent
(0024134)
KiloByte (manager)
2013-10-02 14:51

This bug is still real and I just reproduced it.

As for "honestly not worth it", I think it's serious enough that the vault should be removed if it can't be fixed.

The original reason, them being just lua renames, is gone. But unfortunately, they have been made a regular spawn elsewhere.
(0028658)
MarvinPA (developer)
2015-03-17 19:54

This vault has been removed.
(0028715)
Xentronium (reporter)
2015-03-26 06:07

Does this also apply to the lair vault where killing the anaconda triggers the dire elephant statues to come to life?
(0028716)
PleasingFungus (administrator)
2015-03-26 06:27

Probably. Those don't block anything, though (iirc?)
(0028717)
Xentronium (reporter)
2015-03-26 07:26

Pretty sure they don't.
(0029247)
auddess (reporter)
2015-06-28 21:40

I don't know how to reopen this, but yes, the dire elephant statues CAN block things. I currently cannot get to a unique ring because I stabbed the sleeping anaconda and none of the statues woke up.

- Issue History
Date Modified Username Field Change
2010-03-19 19:01 angrykoopa New Issue
2010-03-19 23:32 due Note Added: 0003507
2010-03-20 04:37 OG17 Note Added: 0003513
2010-03-20 07:24 due Note Added: 0003514
2010-03-20 15:26 angrykoopa Note Added: 0003520
2010-03-21 01:43 due Note Added: 0003525
2012-02-16 05:39 KiloByte Relationship added has duplicate 0005088
2013-10-02 13:58 Grandiloquent Gentleman Note Added: 0024133
2013-10-02 14:51 KiloByte Note Added: 0024134
2015-03-17 19:54 MarvinPA Note Added: 0028658
2015-03-17 19:54 MarvinPA Status new => resolved
2015-03-17 19:54 MarvinPA Fixed in Branch => 0.16 pre-release branch
2015-03-17 19:54 MarvinPA Resolution open => done
2015-03-17 19:54 MarvinPA Assigned To => MarvinPA
2015-03-26 06:07 Xentronium Note Added: 0028715
2015-03-26 06:27 PleasingFungus Note Added: 0028716
2015-03-26 07:26 Xentronium Note Added: 0028717
2015-06-28 21:40 auddess Note Added: 0029247


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker