Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0011159 [DCSS] Bug Report minor always 2017-07-24 21:55 2017-08-06 23:48
Reporter Pekkekke View Status public  
Assigned To gammafunk
Priority normal Resolution done  
Status closed   Product Branch longterm development (0.25+)
Summary 0011159: Autopickup/explore breaks under specific circumstances
Description I'm just going to describe the steps required to reproduce this because it's hard to explain otherwise.

1) Be at 52/52 items
2) Autoexplore into an item that is set to autopickup
3) Game gives you the 'your bags are full' message
4) Drop an item on the ground

After this, the o key does absolutely nothing. It's like the game doesn't even recognize it as an input. I'm using Chrome and haven't tried to reproduce this on any other systems or explorers, but this is entirely reproducible on this PC on Chrome.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0031738)
Pekkekke (reporter)
2017-07-24 22:13

I missed a step. Oops.

3.5) Press o again. The game gives the "Do you want to ignore this item?" prompt. Press 'N' to tell the game not to ignore the item.
(0031745)
Yermak (reporter)
2017-08-02 14:19

I'll chime in with a comment:
You stumble onto an item eligible for autopickup while being at 52/52 and game asks you
"Could not pick up an item here; shall I ignore it?"

If you press spacebar as an answer to this question, then 'o' key will continue to function normally, and if you press 'Esc' then 'o' will stop functioning until you move.
(0031746)
advil (administrator)
2017-08-02 22:57

I can confirm this, seems to be from a recent change to autoexplore. For now as a workaround, using ; to trigger autopickup on your current square once you've dropped something still works, and then o can proceed as normal. (Or if you preemptively drop something without triggering the ignore y/n message, o will also work.)
(0031748)
gammafunk (administrator)
2017-08-03 17:26

Should be fixed in 0.21-a0-156-g77413b7, thanks! Please reopen if you still observer this problem after the next rebuild.
(0031755)
Pekkekke (reporter)
2017-08-06 23:48

Fixed in latest trunk version.

- Issue History
Date Modified Username Field Change
2017-07-24 21:55 Pekkekke New Issue
2017-07-24 22:13 Pekkekke Note Added: 0031738
2017-08-02 14:19 Yermak Note Added: 0031745
2017-08-02 22:57 advil Note Added: 0031746
2017-08-02 22:57 advil Status new => confirmed
2017-08-03 17:26 gammafunk Note Added: 0031748
2017-08-03 17:26 gammafunk Status confirmed => resolved
2017-08-03 17:26 gammafunk Fixed in Branch => 0.20 development branch
2017-08-03 17:26 gammafunk Resolution open => done
2017-08-03 17:26 gammafunk Assigned To => gammafunk
2017-08-06 23:48 Pekkekke Note Added: 0031755
2017-08-06 23:48 Pekkekke Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker