Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0011151 [DCSS] Bug Report minor have not tried 2017-07-17 11:37 2017-10-06 23:48
Reporter Leszczynek View Status public  
Assigned To MarvinPA
Priority normal Resolution done  
Status closed   Product Branch 0.21 ancient branch
Summary 0011151: Gnolls (const attributes version) are prompted with zero stat warning on item removal
Description See screen attached.

Doesn't make sense because the current gnolls' attributes cannot be changed. As expected, despite the warning, nothing happens after removal.
Additional Information
Tags No tags attached.
Attached Files png file icon zero stat prompt gnoll bug.png [^] (10,497 bytes) 2017-07-17 11:37

- Relationships

-  Notes
(0031730)
Floodkiller (reporter)
2017-07-17 13:35

Forgot to add a check for Gnolls in item-use.cc for _safe_to_remove_or_wear (line 1314). Will submit a PR this afternoon if it isn't already fixed by then.
(0031733)
Floodkiller (reporter)
2017-07-18 01:41
edited on: 2017-07-18 01:44

Submitted as PR 574.

(0031862)
Leszczynek (reporter)
2017-10-03 08:14

Can someone close this bug? It was fixed as far as I remember, but it's no longer relevant anyway since there's a new version of gnolls in trunk.

- Issue History
Date Modified Username Field Change
2017-07-17 11:37 Leszczynek New Issue
2017-07-17 11:37 Leszczynek File Added: zero stat prompt gnoll bug.png
2017-07-17 13:35 Floodkiller Note Added: 0031730
2017-07-18 01:41 Floodkiller Note Added: 0031733
2017-07-18 01:44 Floodkiller Note Edited: 0031733
2017-10-03 08:14 Leszczynek Note Added: 0031862
2017-10-06 23:48 MarvinPA Status new => resolved
2017-10-06 23:48 MarvinPA Fixed in Branch => 0.21 development branch
2017-10-06 23:48 MarvinPA Resolution open => done
2017-10-06 23:48 MarvinPA Assigned To => MarvinPA
2017-10-06 23:48 MarvinPA Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker