Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0011137 [DCSS] Bug Report major have not tried 2017-07-07 21:54 2017-12-31 09:28
Reporter 4Hooves2Appendages View Status public  
Assigned To aidanholm
Priority normal Resolution done  
Status resolved   Product Branch experimental branch
Summary 0011137: Area exclusions around staircases don't prevent moving up stairs into excluded area.
Description I excluded a sleeping hydra on L:5. This placed the exclusion zone on a staircase 2 tiles away from the beast.

Then I explored L:6 and found an identified staircase.

When I took the stairs up I was next to the (now) alert hydra, standing on excluded staircase. (Good thing I have blink.)

Of course I could've checked the floor before using the stairs, but I didn't realise it was necessary.
Additional Information
Tags No tags attached.
Attached Files

- Relationships
has duplicate 0006657resolvedaidanholm Travel exclusions do not consider stairs 

-  Notes
(0032010)
aidanholm (developer)
2017-12-31 09:28

Thanks for reporting; fixed at https://github.com/crawl/crawl/commit/87dc6a9e9dbd [^]

- Issue History
Date Modified Username Field Change
2017-07-07 21:54 4Hooves2Appendages New Issue
2017-12-31 09:28 aidanholm Note Added: 0032010
2017-12-31 09:28 aidanholm Status new => resolved
2017-12-31 09:28 aidanholm Fixed in Branch => 0.21 development branch
2017-12-31 09:28 aidanholm Resolution open => done
2017-12-31 09:28 aidanholm Assigned To => aidanholm
2018-03-23 20:21 aidanholm Relationship added duplicate of 0006657
2018-03-23 20:22 aidanholm Relationship replaced has duplicate 0006657


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker