Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0011066 [DCSS] Bug Report text have not tried 2017-05-19 11:33 2017-07-05 07:21
Reporter Fingolfin View Status public  
Assigned To gammafunk
Priority normal Resolution done  
Status resolved   Product Branch 0.21 ancient branch
Summary 0011066: Autoexplore tells me that there is a transporter even though I haven't seen it
Description I went down a level and hit 'o' to explore. I was in a corridor, and only went a couple steps before finding out that it was blocked by an alarm trap. At this point, when I hit 'o' again (just to make sure), the game tells me "Partly explored, unvisited transporter and can't reach some places", even though I haven't seen the transporter yet, I've only seen like 15 tiles of the level.
I'm playing on CXC as Fingolfin.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0031710)
gammafunk (administrator)
2017-07-05 07:20

Should be fixed in 0.21-a0-104-g7b58145, thanks. Issue was counting transporter info towards autoexplore without properly checking that the player had in fact seen the transporter.

- Issue History
Date Modified Username Field Change
2017-05-19 11:33 Fingolfin New Issue
2017-07-05 07:20 gammafunk Note Added: 0031710
2017-07-05 07:20 gammafunk Status new => resolved
2017-07-05 07:20 gammafunk Fixed in Branch => 0.20 development branch
2017-07-05 07:20 gammafunk Resolution open => done
2017-07-05 07:20 gammafunk Assigned To => gammafunk


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker