Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0011052 [DCSS] Bug Report minor always 2017-05-05 22:04 2017-06-30 07:24
Reporter minmay View Status public  
Assigned To MarvinPA
Priority normal Resolution done  
Status closed   Product Branch 0.21 ancient branch
Summary 0011052: minmay_lair_oklob_tunnel has too many plants, bizarre lava vein
Description Here is the original vault submission:
NAME:   minmay_lair_oklob_tunnel
ORIENT: southwest
DEPTH:  Lair
MONS: plant / oklob plant w:1 / nothing w:15
MAP
xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
xxxxxxxxxxxxxxxxxxxxxxxxxxxx11xxx111....
xxxxxxxxxxxxxxxxxxxxxx111xxxx111xx111..@
xxxxxxxxxx111xxx11xxxxx111111111111111..
xxxxxxxxx11xxxx11xxxx111111111111111111x
xxxxxxxxx1xxxxxx11111111111111111111x1xx
xxxxxxxxx11xx1111111111111xxx11111xxxxxx
xxxx11xx1111111111111111111xxxxxx111xxxx
xxxxx1111111111111xx111xxx11xxxxxxxxxxxx
x|%%+11111111111xxxxxx11xxxxxxxxxxxxxxxx
xxxxxxx11111xxx11xxxxxxxxxxxxxxxxxxxxxxx
xxxxxx11xxx11xxxxxxxxxxxxxxxxxxxxxxxxxxx
xxxxxxxxxxxx111xxxxxxxxxxxxxxxxxxxxxxxxx
xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
ENDMAP


At some point, it was changed to this:
NAME:   minmay_lair_oklob_tunnel
DEPTH:  Lair, !Lair:$
ORIENT: southwest
MONS:   plant, oklob plant
NSUBST: 1 = 4:2 / 4 = 10 / *:1
MAP
xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
xxllllllllxxxxxxxxxxxxxxxxxxx11xxx111.....
xxlllllllxxxxxxxxxxxxxx111xxxx111xx111...@
xxlllllxxxx111xxx11xxxxx111111111111111..x
xxllxxxxxx11xxxx11xxxx111111111111111111xx
xxllllxxxx1xxxxxx11111111111111111111x1xx
xxllxxxxxx11xx1111111111111xxx11111xxxxxx
xxllx11xx1111111111111111111xxxxxx111x
xxlxxx1111111111111xx111xxx11xxxxxxxxx
xxlx%+11111111111xxxxxx11xxxxx
xxlx%xxx11111xxx11xxxxxxxxxx
xxlx|xx11xxx11xxxxx
xxlxxxxxxxxxx111xx
xxllllllxxxxxxxxx
xxxx>llxxxx
xxxxxxxxx
ENDMAP


I have no problem with the change from binomial probability to NSUBST. However, this new version has two problems.
1. It replaces ALL the 1s with plants instead of 44% of them. A vault placing over 160 plants is excessive.
2. I'm not sure whether the secret lava vein was an intentional addition or a weird mistake, but either way, it provides an advantage to spoiled players because they can get free piety from lava monsters in exchange for a dig charge or LRD cast. If it stays it should have no_monster_gen, along with the escape hatch square.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
2017-05-05 22:04 minmay New Issue
2017-05-05 22:15 neil Description Updated
2017-05-05 22:20 MarvinPA Status new => resolved
2017-05-05 22:20 MarvinPA Fixed in Branch => 0.20 development branch
2017-05-05 22:20 MarvinPA Resolution open => done
2017-05-05 22:20 MarvinPA Assigned To => MarvinPA
2017-06-30 07:24 minmay Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker