Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0011008 [DCSS] Bug Report minor have not tried 2017-04-12 17:26 2017-04-30 18:44
Reporter Leszczynek View Status public  
Assigned To PleasingFungus
Priority normal Resolution done  
Status resolved   Product Branch 0.21 ancient branch
Summary 0011008: God enacts wrath upon the player when "neutral towards you"
Description Experienced with Okawaru and his summons after switching to TSO.

Current trunk's _raw_penance_message in describe-god.cc seems to treat actual neutrality and penance < initial penance cases the same, printing out "neutral towards you" in the ?/G screen.

If this is intended, I'd like to ask for some clarity between "almost neutral but still angry" and actually neutral states.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0031584)
Leszczynek (reporter)
2017-04-12 19:04

"and penance < initial penance cases the same"
was supposed to be
"and penance < (initial penance / 4) cases the same"
(0031631)
PleasingFungus (administrator)
2017-04-30 18:44

Fixed in 89cde08, thanks!

- Issue History
Date Modified Username Field Change
2017-04-12 17:26 Leszczynek New Issue
2017-04-12 19:04 Leszczynek Note Added: 0031584
2017-04-30 18:44 PleasingFungus Note Added: 0031631
2017-04-30 18:44 PleasingFungus Status new => resolved
2017-04-30 18:44 PleasingFungus Fixed in Branch => 0.20 development branch
2017-04-30 18:44 PleasingFungus Resolution open => done
2017-04-30 18:44 PleasingFungus Assigned To => PleasingFungus


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker