Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0010965 [DCSS] Bug Report minor have not tried 2017-03-07 22:53 2017-03-08 16:22
Reporter JimmahDean View Status public  
Assigned To neil
Priority normal Resolution done  
Status closed   Product Branch 0.21 ancient branch
Summary 0010965: WebTiles turns black when firing a missile
Description Save Backup: http://crawl.akrasiac.org/saves/JimmahDean-crawl-git-e7e240fbe1-170307-1645.tar.bz2 [^]

I created this character a few days ago to use beem to answer somebody's question and finally am getting around to playing the character, after transferring to a newer trunk version twice. I attempted to kill a goblin and the screen blacked out the moment I went to target magic dart. Upon cancelling the targeting, or firing the missile the screen goes back to normal, but goes black again whenever trying to cast. The same effect occurs when pressing (f)ire, despite having nothing quivered.
Additional Information
Tags No tags attached.
Attached Files bz2 file icon JimmahDean-crawl-git-e7e240fbe1-170307-1645.tar.bz2 [^] (49,283 bytes) 2017-03-07 23:26

- Relationships
duplicate of 0007201resolvedneil "use_fake_cursor = false" blanks the screen when targetting in WebTiles 

-  Notes
(0031525)
neil (administrator)
2017-03-08 00:39

Hm, I can reproduce this reliably, but only in Webtiles and only with JimmahDean's rc file: http://crawl.akrasiac.org/rcfiles/crawl-git/JimmahDean.rc [^]

I don't need the macros file to reproduce it, so it's not the cast_spell function.
(0031526)
neil (administrator)
2017-03-08 00:51

It appears to be use_fake_cursor = false
(0031527)
JimmahDean (reporter)
2017-03-08 01:03

Ohhh, that makes sense. I made the DrCj to try out a few things posted on /r/dcss about how to get rid of the highlighted @ and added use_fake_cursor = false to the rcfile.
(0031532)
neil (administrator)
2017-03-08 16:22

Fixed in trunk (0.20-a0-840-gfcb4723), thanks!

- Issue History
Date Modified Username Field Change
2017-03-07 22:53 JimmahDean New Issue
2017-03-07 23:26 advil File Added: JimmahDean-crawl-git-e7e240fbe1-170307-1645.tar.bz2
2017-03-08 00:39 neil Note Added: 0031525
2017-03-08 00:51 neil Note Added: 0031526
2017-03-08 01:03 JimmahDean Note Added: 0031527
2017-03-08 15:20 advil Relationship added duplicate of 0007201
2017-03-08 16:22 neil Note Added: 0031532
2017-03-08 16:22 neil Status new => resolved
2017-03-08 16:22 neil Fixed in Branch => 0.20 development branch
2017-03-08 16:22 neil Resolution open => done
2017-03-08 16:22 neil Assigned To => neil
2017-03-08 16:22 neil Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker