Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0010960 [DCSS] Bug Report minor have not tried 2017-03-02 21:34 2017-03-03 16:27
Reporter Undo View Status public  
Assigned To PleasingFungus
Priority normal Resolution done  
Status resolved   Product Branch 0.21 ancient branch
Summary 0010960: random effects explodes into a cloud of software bugs
Description I evoked a random effects wand, producing the following:

 The beam explodes into a cloud of software bugs!
 The iceblast engulfs the seven-headed hydra.
 The seven-headed hydra is severely wounded.
_Evoking this partially-identified wand wasted a few charges.

Dump is attached.
Additional Information
Tags No tags attached.
Attached Files txt file icon bugdump.txt [^] (21,593 bytes) 2017-03-02 21:34 [Show Content]

- Relationships
parent of 0011063resolvedadvil Cloud of software bugs from Makhleb (beam.cc issue) 

-  Notes
(0031516)
advil (administrator)
2017-03-03 04:43

Confirmed, both fireball and iceblast are broken with random effects (other wands seem ok). Looks like this was caused by 4a616ededea7. Thanks for reporting.

Here's a debug log if someone wants it:

 Spell 0000351, power=15
 missile tracer [debugging ray] (66,59) to (66,0): gl=88 col=15 flav=2 hit=1500
 dam=1500d1 range=8
 zapping: power=15
 missile* [fireball] (66,59) to (66,0): gl=42 col=4 flav=3 hit=40 dam=3d5
 range=7
 The beam explodes into a cloud of software bugs!
 explosion at (66, 54) : g=247 c=4 f=3 hit=40 dam=3d5 r=1
(0031517)
PleasingFungus (administrator)
2017-03-03 16:27

Fixed in 00179d9, thanks!

- Issue History
Date Modified Username Field Change
2017-03-02 21:34 Undo New Issue
2017-03-02 21:34 Undo File Added: bugdump.txt
2017-03-03 04:43 advil Note Added: 0031516
2017-03-03 04:44 advil Status new => confirmed
2017-03-03 16:27 PleasingFungus Note Added: 0031517
2017-03-03 16:27 PleasingFungus Status confirmed => resolved
2017-03-03 16:27 PleasingFungus Fixed in Branch => 0.20 development branch
2017-03-03 16:27 PleasingFungus Resolution open => done
2017-03-03 16:27 PleasingFungus Assigned To => PleasingFungus
2017-05-16 14:59 advil Relationship added parent of 0011063


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker