Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0010944 [DCSS] Bug Report tweak have not tried 2017-02-18 19:46 2017-08-11 21:57
Reporter damerell View Status public  
Assigned To PleasingFungus
Priority normal Resolution done  
Status closed   Product Branch 0.21 old branch
Summary 0010944: Zin recite power possibly not working as designed
Description zin_recite_power() in god-abil.cc says:

    // You can affect up to (30+30)/2 = 30 'power' (HD).

I infer from this that the intention is that with maximum piety and Invo one can Recite to 30HD orbs of fire.

However, the actual check is:

        if (mon->get_hit_dice() >= zin_recite_power())

which means that a 30HD OOF can never be Recited to.

If this _is_ the intended behaviour, the message ("not zealous enough") is perhaps somewhat confusing since, unlike any other monster where this message is seen, one can never be zealous enough.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0031540)
PleasingFungus (administrator)
2017-03-09 07:08

Fixed the comment in 77b00a3. I'm not super concerned about the 'zealous' message.
(0031541)
PleasingFungus (administrator)
2017-03-09 07:08

Thanks for reporting!

- Issue History
Date Modified Username Field Change
2017-02-18 19:46 damerell New Issue
2017-03-09 07:08 PleasingFungus Note Added: 0031540
2017-03-09 07:08 PleasingFungus Status new => resolved
2017-03-09 07:08 PleasingFungus Fixed in Branch => 0.20 development branch
2017-03-09 07:08 PleasingFungus Resolution open => done
2017-03-09 07:08 PleasingFungus Assigned To => PleasingFungus
2017-03-09 07:08 PleasingFungus Note Added: 0031541
2017-08-11 21:57 damerell Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker