Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0010940 [DCSS] Bug Report crash always 2017-02-14 06:44 2017-02-14 16:53
Reporter nstoddard View Status public  
Assigned To MarvinPA
Priority normal Resolution done  
Status resolved   Product Branch experimental branch
Summary 0010940: In trunk, wearing a non-armor item crashes the game
Description To repro: play on crawl.akrasiac.org, DCSS trunk, and press W (wear), * (to be able to select non-armor items), and select any non-armor item. The game will crash.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0031480)
glennmatthews (reporter)
2017-02-14 15:24

Reproducible locally on 0.20-a0-642-g4ff03ff08c:

ASSERT(item.base_type == OBJ_ARMOUR) in 'item-prop.cc' at line 1453 failed.

Version: Dungeon Crawl Stone Soup 0.20-a0-642-g4ff03ff08c
Platform: unix (OS X)
Bits: 64
Game mode: normal
Tiles: yes

Command line: ./crawl

RC options:
restart_after_game = true


Crash caused by signal 0000004: Illegal instruction: 4

Obtained 11 stack frames.
0x000000010aa0ccb5: write_stack_trace(__sFILE*, int) + 117
0x000000010aa13e4a: do_crash_dump() + 1226
0x000000010aa0ca50: crash_signal_handler(int) + 192
0x00007fffb6ad1bba: _sigtramp + 26
0x0000000000747369: 0x0 + 7631721
0x000000010aa15fe6: AssertFailed(char const*, char const*, int, char const*, ...) + 358
0x000000010abb8d69: get_armour_slot(item_def const&) + 73
0x000000010ab9fa8a: wear_armour(int) + 298
0x000000010b0967d9: _input() + 1529
0x000000010b08d845: main + 8933
0x000000010a973314: start + 52
(0031481)
glennmatthews (reporter)
2017-02-14 15:28

Guessing this may be a side effect of https://github.com/crawl/crawl/pull/423. [^] Investigating.
(0031482)
glennmatthews (reporter)
2017-02-14 15:52

Confirmed, not reproducible before the aforementioned PR.
(0031483)
glennmatthews (reporter)
2017-02-14 16:10

Candidate fix: https://github.com/crawl/crawl/pull/457 [^]
(0031485)
MarvinPA (developer)
2017-02-14 16:53

Fixed by PR 0000457.

- Issue History
Date Modified Username Field Change
2017-02-14 06:44 nstoddard New Issue
2017-02-14 15:24 glennmatthews Note Added: 0031480
2017-02-14 15:28 glennmatthews Note Added: 0031481
2017-02-14 15:52 glennmatthews Note Added: 0031482
2017-02-14 16:10 glennmatthews Note Added: 0031483
2017-02-14 16:53 MarvinPA Note Added: 0031485
2017-02-14 16:53 MarvinPA Status new => resolved
2017-02-14 16:53 MarvinPA Fixed in Branch => 0.20 development branch
2017-02-14 16:53 MarvinPA Resolution open => done
2017-02-14 16:53 MarvinPA Assigned To => MarvinPA


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker