Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0010926 [DCSS] Bug Report block always 2017-02-01 12:46 2017-02-06 20:08
Reporter sagitter View Status public  
Assigned To neil
Priority normal Resolution done  
Status closed   Product Branch 0.19 ancient branch
Summary 0010926: crawl-0.19.4 does not compile on Fedora
Description Hi all.

'crawl-0.19.4' does not compile on Fedora rawhide (development branch) because of various compiler errors; please, see following log for details:
https://kojipkgs.fedoraproject.org//work/tasks/924/17540924/build.log [^]

SO Fedora with gcc-7.0.1
List of libraries used for compiling: https://kojipkgs.fedoraproject.org//work/tasks/924/17540924/root.log [^]

Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0031459)
neil (administrator)
2017-02-05 19:49

This should be fixed now in trunk (0.20-a0-570-g5e19f30) and 0.19 (0.19.4-1-gdf1a1cb). We were missing several instances #include <functional>. It worked for old g++ because other system headers happened to pull in <functional>.
(0031471)
sagitter (reporter)
2017-02-06 18:35

Fixed.
Thank you.

- Issue History
Date Modified Username Field Change
2017-02-01 12:46 sagitter New Issue
2017-02-05 19:49 neil Note Added: 0031459
2017-02-05 19:49 neil Status new => resolved
2017-02-05 19:49 neil Fixed in Branch => 0.19 stable branch
2017-02-05 19:49 neil Resolution open => done
2017-02-05 19:49 neil Assigned To => neil
2017-02-06 18:35 sagitter Note Added: 0031471
2017-02-06 20:07 neil Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker