Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0010919 [DCSS] Bug Report minor have not tried 2017-01-27 18:52 2017-02-16 01:57
Reporter nubinia View Status public  
Assigned To Brannock
Priority normal Resolution done  
Status resolved   Product Branch 0.21 old branch
Summary 0010919: Ashenzari doesn't id axe in shallow water.
Description My weapon is cursed, I'm at ***** with Ash, but the stash in a worms' lair in Spider:1 shows as

Things that are here:
_24 stones; an uncursed glowing battleaxe
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0031475)
advil (developer)
2017-02-09 16:24

I think the problem is not with shallow water but rather with stacking (i.e. the 24 stones in this report). The current behavior is that ash will not id a weapon at a distance when it's in a stack and you can't see it (not a bug), and ash will not id a weapon that is lower in a stack you are standing on and therefore can see (this seems like a bug to me). The weapon still id's on pickup in my testing.

As far as I can tell this happens independent of shallow water, and a single item in shallow water behaves as expected.
(0031477)
Yermak (reporter)
2017-02-09 22:14

0010580
(0031487)
Brannock (developer)
2017-02-16 01:56

Fixed in 4bc97ff5, thank you for reporting.

- Issue History
Date Modified Username Field Change
2017-01-27 18:52 nubinia New Issue
2017-02-09 16:24 advil Note Added: 0031475
2017-02-09 22:14 Yermak Note Added: 0031477
2017-02-16 01:56 Brannock Note Added: 0031487
2017-02-16 01:56 Brannock Status new => resolved
2017-02-16 01:56 Brannock Fixed in Branch => 0.20 development branch
2017-02-16 01:56 Brannock Resolution open => done
2017-02-16 01:56 Brannock Assigned To => Brannock


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker