Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0010914 [DCSS] Patches minor always 2017-01-23 18:38 2017-02-25 15:08
Reporter advil View Status public  
Assigned To
Priority normal Resolution done  
Status closed   Product Branch 0.21 ancient branch
Summary 0010914: bugfix for fsim defense with spiny demonspawns
Description When running an fsim defense with a spiny demonspawn, the monster dies at some point during the fsim because of spiny, but hp isn't reset on the defense code path. This leads to a bad fsim and a dangling dead monster, then messages like "mgrd at (54,32) points at dead monster DEAD MONSTER". (Discovered while trying to figure out 10472.)

Fixed with the attached one-line patch.
Additional Information
Tags No tags attached.
Attached Files ? file icon spiny_fsim.diff [^] (586 bytes) 2017-01-23 18:38 [Show Content]

- Relationships

-  Notes
(0031470)
advil (administrator)
2017-02-06 15:38

|amethyst merged this in 60d86990370f so this could be closed.

- Issue History
Date Modified Username Field Change
2017-01-23 18:38 advil New Issue
2017-01-23 18:38 advil File Added: spiny_fsim.diff
2017-02-06 15:38 advil Note Added: 0031470
2017-02-25 15:08 neil Status new => closed
2017-02-25 15:08 neil Resolution open => done
2017-02-25 15:08 neil Fixed in Branch => 0.20 development branch


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker