Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0010904 [DCSS] Bug Report minor have not tried 2017-01-15 10:06 2017-02-22 06:51
Reporter nubinia View Status public  
Assigned To neil
Priority normal Resolution done  
Status resolved   Product Branch 0.21 ancient branch
Summary 0010904: Experience potion failed to advance my level
Description So I'm now at XL: 15 Next: -123%

I got the extra skill levels.
Additional Information
Tags No tags attached.
Attached Files png file icon Exp bug.png [^] (207,636 bytes) 2017-01-15 13:22
? file icon Olive.cs [^] (56,376 bytes) 2017-02-21 05:51

- Relationships
related to 0010435new Felid went up one level after potion of experience, but shows that I have enough experience to go up another level 

-  Notes
(0031418)
Ge0ff (reporter)
2017-01-15 13:22

I had a similar problem recently. While playing a Felid (0 deaths) I drank an unidentified potion of experience and got "XL: 15 Next: -106%". After saving and reloading the game I got the "_You have reached level 16!" message ("XL: 16 Next: 40%"). The version was 0.19, Web Tiles.
(0031419)
nubinia (reporter)
2017-01-15 20:43

Went up a level next time I logged in
(0031492)
advil (administrator)
2017-02-21 05:23
edited on: 2017-02-21 05:23

tv for one of these, for future reference:

!lg Ge0ff gid=Ge0ff:cue:20170004195346S -tv:channel=debug:<T39550:>40000


(0031493)
advil (administrator)
2017-02-21 05:52
edited on: 2017-02-21 05:54

I managed to replicate this once, but I'm not yet entirely sure how. I've attached a save "Olive.cs" from immediately after the following log in the state where the HUD shows "XL: 17 Next: 121%". (The save is accidentally named after a char in a save from the related bug report but this is just because I hit enter at the wrong time, it's a new wizmode character in 0.20 trunk.) If you load this save in unmodified crawl it'll probably advance the level on load.

 You feel more experienced!
 XP before: 164600

 0.18 of 153263..215630 to 215630..289976
 XP after: 229144

 You feel omnipotent.
 You have reached level 17!
_HP changed: 100/100 -> 100/104
 You feel more experienced!
 XP before: 229144

 0.18 of 215630..289976 to 289976..376299
 XP after: 305667

_You feel omnipotent.


(0031494)
Brannock (developer)
2017-02-21 06:44

Another player who's experienced a similar problem/bug:

<Lightli> anyways before I continue I'll just relink the savefile again if you need it
<Lightli> http://crawl.beRotato.org/crawl/saves/Lightli-crawl-git-bd4582c47f-170221-0543.tar.bz2 [^]
(0031495)
advil (administrator)
2017-02-22 05:42

This bug has defeated me for now. For the record, it's not:

* related to the !xp being un-id'd
* related to felid
* related to stat-up (a sighup on a stat-up produces similar results, but I'm pretty sure the log would show the message still, and not all of the recorded problems were stat-up levels).
* related to the skill training menu (my save had all skills at 27).
* anything to do with the exact numeric xp values (I created a wizmode command to set this to try to replicate the situation in my save)
* repeatable by doing the same actions in the same order from the game start (tried to do this with my save)
* related to being online, or to webtiles.
* related to zigs

Things I couldn't fully eliminate:

* something to do with it being the only !xp in inventory (i.e. something to do with the inventory removal code)
* random memory corruption or overwriting (remotely conceivable: potion sub_type somehow gets changed during various cleanup code. But it's not obvious how this could be happening.)
(0031496)
neil (administrator)
2017-02-22 06:51

Fixed in trunk (0.20-a0-733-gf92fd71) and stable (0.19.4-10-g532645f), thanks! Thanks especially to advil for the debugging work.

This happened every single time you drank the last !exp from a stack on the floor. It apparently also could happen, but rarely, when drinking the last !exp from a stack in inventory: advil managed to reproduce the inventory case, but not reliably.

- Issue History
Date Modified Username Field Change
2017-01-15 10:06 nubinia New Issue
2017-01-15 13:22 Ge0ff Note Added: 0031418
2017-01-15 13:22 Ge0ff File Added: Exp bug.png
2017-01-15 14:44 MarvinPA Relationship added related to 0010435
2017-01-15 20:43 nubinia Note Added: 0031419
2017-02-21 05:23 advil Note Added: 0031492
2017-02-21 05:23 advil Note Edited: 0031492
2017-02-21 05:51 advil File Added: Olive.cs
2017-02-21 05:52 advil Note Added: 0031493
2017-02-21 05:53 advil Note Edited: 0031493
2017-02-21 05:54 advil Note Edited: 0031493
2017-02-21 06:44 Brannock Note Added: 0031494
2017-02-22 05:42 advil Note Added: 0031495
2017-02-22 06:51 neil Note Added: 0031496
2017-02-22 06:51 neil Status new => resolved
2017-02-22 06:51 neil Fixed in Branch => 0.19 stable branch
2017-02-22 06:51 neil Resolution open => done
2017-02-22 06:51 neil Assigned To => neil


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker