Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0010877 [DCSS] Patches minor always 2017-01-05 04:24 2018-04-29 03:34
Reporter bel View Status public  
Assigned To wheals
Priority normal Resolution done  
Status resolved   Product Branch 0.21 ancient branch
Summary 0010877: Goldify spellbooks
Description There are some issues with this (saving/reloading does not work yet).

Goldify (or runify) spellbooks. This is achieved by having a vector member in class "player" called "books_in_inventory". Picked up books go there instead of in the inventory. For characters which start with a book, the book is initially placed in the inventory, identified, then goldified and removed from inventory (an awful hack, but I don't know enough about the code to do it more elegantly).

Manuals are still treated normally. I tried to goldify them as well, but the code went into an infinite loop. In any case, there's no obvious way to show multiple manuals in the display otherwise, so it's probably better to keep them as it is.

Breaks old savefiles because books_in_inventory needs to be marshalled/unmarshalled. Saving/reloading does not actually work because tags.cc crashes with an error ("ERROR in 'tags.cc' at line 4089: Invalid item: book of Changes"). The code in tags.cc is currently commented out. If someone can tell me what's causing it, I'll fix it.

TODO: Fix saving/reloading. Optional: Remove Trog's book burning. Make Vehumet gift an artifact spellbook containing 1/3 spells, instead of a spell using the "M" screen.
Additional Information
Tags No tags attached.
Attached Files ? file icon 0001-Goldify-spellbooks.patch [^] (6,718 bytes) 2017-01-05 04:24 [Show Content]

- Relationships

-  Notes
(0031392)
bel (reporter)
2017-01-05 04:30

See also this thread (https://crawl.develz.org/tavern/viewtopic.php?f=8&t=22303) [^] in Tavern.
(0032205)
wheals (administrator)
2018-04-29 03:33

Done in trunk, using a different patch.

- Issue History
Date Modified Username Field Change
2017-01-05 04:24 bel New Issue
2017-01-05 04:24 bel File Added: 0001-Goldify-spellbooks.patch
2017-01-05 04:30 bel Note Added: 0031392
2018-04-29 03:33 wheals Note Added: 0032205
2018-04-29 03:33 wheals Status new => resolved
2018-04-29 03:33 wheals Fixed in Branch => 0.22 development branch
2018-04-29 03:33 wheals Resolution open => done
2018-04-29 03:33 wheals Assigned To => wheals


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker