Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0010848 [DCSS] Bug Report minor always 2016-12-15 07:41 2016-12-17 16:05
Reporter papilio View Status public  
Assigned To MarvinPA
Priority normal Resolution done  
Status resolved   Product Branch 0.21 ancient branch
Summary 0010848: Death scarabs from infestation spell turn hostile
Description When you cast infestation on enemy, and kill that enemy with wand of iceblast, fireball or such things, then death scarab appears hostile.

I think this's cause the game judged that I hit them with wand of iceblast.

This is weird, because the correct logical flow should be

Iceblast -> kill enemy (the icy blast ends here) -> scarabs burst out after the death of the foe.

Additional Information
Tags No tags attached.
Attached Files

- Relationships
related to 0010870new Unintended coding interaction between death channel and AOE spells 

-  Notes
(0031350)
MarvinPA (developer)
2016-12-17 16:05

Fixed, thanks for reporting!

- Issue History
Date Modified Username Field Change
2016-12-15 07:41 papilio New Issue
2016-12-17 16:05 MarvinPA Note Added: 0031350
2016-12-17 16:05 MarvinPA Status new => resolved
2016-12-17 16:05 MarvinPA Fixed in Branch => 0.20 development branch
2016-12-17 16:05 MarvinPA Resolution open => done
2016-12-17 16:05 MarvinPA Assigned To => MarvinPA
2017-01-02 01:51 PleasingFungus Relationship added related to 0010870


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker