Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0010760 [DCSS] Bug Report minor always 2016-11-04 01:16 2017-10-14 19:05
Reporter PleasingFungus View Status public  
Assigned To advil
Priority normal Resolution done  
Status resolved   Product Branch 0.19 ancient branch
Summary 0010760: Skill menu cursor deselects (vanishes) when moved repeatedly to the right
Description On the skill menu (m), hitting right arrow repeatedly causes the cursor to vanish. This probably shouldn't happen, but I spent an hour trying to figure out why it is happening & failed.

PrecisionMenu::process_key() deselects things when MenuFreeform::process_input() returns INPUT_FOCUS_RELEASE_RIGHT. why doesn’t this happen when we return INPUT_FOCUS_RELEASE_LEFT? (we don’t get RELEASE_UP or _DOWN, because they loop)
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0031886)
advil (administrator)
2017-10-14 19:05

Fixed in https://github.com/crawl/crawl/commit/917015170dac [^] !

- Issue History
Date Modified Username Field Change
2016-11-04 01:16 PleasingFungus New Issue
2017-10-14 19:05 advil Note Added: 0031886
2017-10-14 19:05 advil Status new => resolved
2017-10-14 19:05 advil Fixed in Branch => 0.21 development branch
2017-10-14 19:05 advil Resolution open => done
2017-10-14 19:05 advil Assigned To => advil


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker