Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0010696 [DCSS] Bug Report minor always 2016-09-24 05:31 2017-02-25 19:23
Reporter drewnix View Status public  
Assigned To neil
Priority normal Resolution done  
Status resolved   Product Branch 0.19 ancient branch
Summary 0010696: Hit "ASSERT(!place_info.is_global()) in 'tags.cc' at line 3873 failed." attempting to load save from previous version
Description Hit attempting to use a character saved from a earlier version of crawl (not sure which)

ASSERT(!place_info.is_global()) in 'tags.cc' at line 3873 failed.

ASSERT(!place_info.is_global()) in 'tags.cc' at line 3873 failed.

We crashed! This is likely due to a bug in Crawl.
Please submit a bug report at https://crawl.develz.org/mantis/ [^] and include:
- The crash report: /Users/andrew/Library/Application Support/Dungeon Crawl Stone Soup/morgue/crash-dxla-20160923-202210.txt
- Your save file: /Users/andrew/Library/Application Support/Dungeon Crawl Stone Soup/saves/dxla.cs
- A description of what you were doing when this crash occurred.

Illegal instruction: 4
Additional Information
Tags No tags attached.
Attached Files txt file icon crash-dxla-20160923-202210.txt [^] (5,869 bytes) 2016-09-24 05:31 [Show Content]
? file icon dxla.cs [^] (86,825 bytes) 2016-09-24 05:31
? file icon 77263-serg.cs [^] (50,598 bytes) 2016-12-26 18:38

- Relationships
has duplicate 0010788closedneil Crash on saved game start after update to 0.19.0 
has duplicate 0010723closedadvil Crash on game load 

-  Notes
(0031500)
advil (administrator)
2017-02-24 05:38

The 77263-serg.cs save looks like something else to me -- it's a tutorial save (!) and it segfaults in 0.20 trunk.

Also, 10788 has another "ASSERT(!place_info.is_global()) in 'tags.cc' at line 3873 failed" save.
(0031509)
neil (administrator)
2017-02-25 15:26

Fixed in trunk (0.20-a0-711-gab781cd and 0.20-a0-712-g4807967) and stable (0.19.4-11-g5e6c2b2), thanks! (and thanks to advil for debugging and doing the fix)

The underlying cause of the problem has been fixed in both trunk and 0.19.
Unfortunately, I don't think we can easily fix the broken saves in 0.19, because the required compatibility checks would cause conflicts when loading 0.19 games into 0.20. You can, however, load the games into trunk or into 0.20 when that is released.
(0031511)
neil (administrator)
2017-02-25 19:23

advil has backported the fix for corrupted saves to stable (0.19.4-12-gccf7e64), so you don't have to wait for 0.20 (or run trunk) to make the saves work again.

Presumably we will have an 0.19.5 release at some point.

- Issue History
Date Modified Username Field Change
2016-09-24 05:31 drewnix New Issue
2016-09-24 05:31 drewnix File Added: crash-dxla-20160923-202210.txt
2016-09-24 05:31 drewnix File Added: dxla.cs
2016-09-24 05:32 drewnix Issue Monitored: drewnix
2016-09-30 19:01 PleasingFungus Status new => confirmed
2016-12-26 18:38 PleasingFungus File Added: 77263-serg.cs
2017-02-24 05:38 advil Note Added: 0031500
2017-02-25 15:26 neil Note Added: 0031509
2017-02-25 15:26 neil Status confirmed => resolved
2017-02-25 15:26 neil Fixed in Branch => 0.19 stable branch
2017-02-25 15:26 neil Resolution open => done
2017-02-25 15:26 neil Assigned To => neil
2017-02-25 15:27 neil Relationship added has duplicate 0010788
2017-02-25 19:23 neil Note Added: 0031511
2017-03-12 17:54 advil Relationship added has duplicate 0010723


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker