Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0010594 [DCSS] Bug Report text have not tried 2016-08-04 00:11 2016-08-04 00:29
Reporter jwoodward48ss View Status public  
Assigned To amalloy
Priority normal Resolution done  
Status resolved   Product Branch 0.19 ancient branch
Summary 0010594: Int-2 ring shows up as Int--2 in stash search prefixes
Description Straightforward bug. My guess is thus:

Code:

write ringStat
##this is str, dex, int
if statBoost > 0 then boostsStat = true
##this determines whether it's good or bad
if boostsStat = true then write "+"
else write "-"
##displays whether ring boosts or decrements stat
...
...
...
write statValue


This would explain why negative, not positive, stat adjustments have - displayed twice.

This probably is very old, but hasn't been noticed for years since who looks at bad rings anyway?
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0030860)
amalloy (developer)
2016-08-04 00:28

Fixed in https://github.com/crawl/crawl/commit/e0cd3b9d06fe. [^] Thanks!

- Issue History
Date Modified Username Field Change
2016-08-04 00:11 jwoodward48ss New Issue
2016-08-04 00:28 amalloy Note Added: 0030860
2016-08-04 00:28 amalloy Status new => resolved
2016-08-04 00:28 amalloy Fixed in Branch => 0.19 development branch
2016-08-04 00:28 amalloy Resolution open => done
2016-08-04 00:28 amalloy Assigned To => amalloy


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker