Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0010513 [DCSS] Bug Report minor always 2016-06-18 11:12 2017-10-12 18:56
Reporter LexAckson View Status public  
Assigned To advil
Priority normal Resolution done  
Status resolved   Product Branch 0.19 ancient branch
Summary 0010513: Too many statuses will wrap into map (only during -more- prompt )
Description My character's statuses wrap into the map view, but only when there is a -more- prompt. When there's no -more- prompt the last status 'Invis' just gets hidden. I've pasted the terminal here and also uploaded a screenshot.
...#†?.#.....#*      ,                LexAckson the Severer
.[.)...#.....#     ,    ,             Deep Dwarf of Ru ******
...##+###....#   ,                    Health: 223/267   ====================----
#####   #....#     ,  ,               Magic:  12/16     ==================------
#...#,  #....# ,                      AC: 21            Str: 32
#...# , #....#  , , * ,, #            EV:  9            Int: 10
'...######...# , ,  *  ..#            SH: 13            Dex: 12
######...#...########....#            XL: 19 Next:  7%  Place: Vaults:1
##...#...#....†.)g[......#            Gold: 2105        Time: 48160.7 (0.0)
.'...#...#.......).......#            a) +2 war axe (flame)
.#...##(###......).......#            -) Quiver unavailable
.##'###(..#..##########..#            Berserk Pois Shroud Slay (7) Contam Drain
Invis
..#..)#(..#..#  , ,, ,   #
..#...#####..#    ,
..#####......###++++### .#
###..........#.8....8.#..#
 You are alive. You are possessed by a berserker rage.
 You are mildly poisoned (223 -> 223).
 You are protected by a distorting shroud.
 Your melee attacks are strengthened by your song.
 You are very lightly contaminated with residual magic.
 Your life force is drained.
 --more--
Additional Information
Tags No tags attached.
Attached Files png file icon dcss_status_bug.png [^] (46,338 bytes) 2016-06-18 11:12

- Relationships

-  Notes
(0031882)
advil (administrator)
2017-10-12 18:55

Thanks for the report. This appears to have been fixed, possibly by accident (I couldn't spot a specific commit), since this report; there have been some improvements and cleanups in status lights / messaging that might have affected this bug. The current behavior in console is that status lights will wrap over two lines and anything beyond that gets hidden; the bad interaction with more doesn't seem to happen any more (@ is a convenient way to test this), the extra status lights just remain hidden.

- Issue History
Date Modified Username Field Change
2016-06-18 11:12 LexAckson New Issue
2016-06-18 11:12 LexAckson File Added: dcss_status_bug.png
2017-10-12 18:55 advil Note Added: 0031882
2017-10-12 18:55 advil Status new => resolved
2017-10-12 18:55 advil Fixed in Branch => 0.21 development branch
2017-10-12 18:55 advil Resolution open => done
2017-10-12 18:55 advil Assigned To => advil


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker