Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0010511 [DCSS] Patches feature N/A 2016-06-18 06:39 2020-03-23 21:43
Reporter Siegurt View Status public  
Assigned To Kate
Priority normal Resolution won't do  
Status resolved   Product Branch 0.19 ancient branch
Summary 0010511: Pakellas experimental
Description This is a slightly different take on Pakellas.

1. You don't regenerate MP on kill.
2. Quick charge reduces wand/rod the max charge of the item.
3. A new ability "Destroy Device" which recharges your MP and produces Potions of magic (Based on remaining charges and piety+evocation)
4. Pakellas continues to gift wands/rods as long as you gain piety.

This seems to work better when I tested it, I felt like I had to think more about my choices about what to break and when, and I didn't feel like I had an unlimited supply of all consumable evocations, but quick charge stretched my supplies to the point where using them frequently was an attractive option.
Additional Information
Tags No tags attached.
Attached Files ? file icon 0001-Pakellas-Experiment-A.patch [^] (30,506 bytes) 2016-06-18 06:39 [Show Content]

- Relationships

-  Notes
(0030656)
Siegurt (reporter)
2016-06-18 07:37

While the mechanisms seem reasonable, the numbers likely need tweaked.
(0030658)
PleasingFungus (administrator)
2016-06-18 08:07
edited on: 2016-06-18 08:22

your dialect is barbaric and 'needs tweaked'!!!

idea seems interesting; don't have a strong opinion on it at present. other devs are more invested in a pak rewrite, so i expect they'll have more to say.

(0030663)
Siegurt (reporter)
2016-06-19 08:00

Are you referring to my C dialect or my english? :)
(0030664)
PleasingFungus (administrator)
2016-06-19 18:24

Latter (but not seriously)
(0030665)
Siegurt (reporter)
2016-06-20 04:59

Well, there's some problems with the former (notably the fall through switch-case in the giftin code) but this was "prototyping" code written maybe in an hour.

If the mechanisms are decided to be good, there's a lot of refactoring that needs to be done, the gifting code should really be a weighted list (maybe that's extended based on piety level or something)

The 'break device' ability should be both better documented and should have a more reasonable formula (probably less random, and giving more earlier, and less later)

But that's the point of prototyping code, just to get a sketch of the idea down so you can fiddle with it and see how it goes.
(0033727)
Kate (developer)
2020-03-23 21:42

Closing this, since Pakellas seems unlikely to return.

- Issue History
Date Modified Username Field Change
2016-06-18 06:39 Siegurt New Issue
2016-06-18 06:39 Siegurt File Added: 0001-Pakellas-Experiment-A.patch
2016-06-18 07:02 Siegurt Issue Monitored: Siegurt
2016-06-18 07:37 Siegurt Note Added: 0030656
2016-06-18 08:07 PleasingFungus Note Added: 0030658
2016-06-18 08:22 PleasingFungus Note Edited: 0030658
2016-06-19 08:00 Siegurt Note Added: 0030663
2016-06-19 18:24 PleasingFungus Note Added: 0030664
2016-06-20 04:59 Siegurt Note Added: 0030665
2019-10-03 22:22 Siegurt Issue End Monitor: Siegurt
2020-03-23 21:42 Kate Note Added: 0033727
2020-03-23 21:42 Kate Status new => resolved
2020-03-23 21:42 Kate Fixed in Branch => 0.25 development branch
2020-03-23 21:42 Kate Resolution open => won't do
2020-03-23 21:42 Kate Assigned To => Kate


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker