Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0010347 [DCSS] Bug Report minor have not tried 2016-04-06 22:23 2016-12-17 18:36
Reporter RoGGa View Status public  
Assigned To PleasingFungus
Priority normal Resolution done  
Status closed   Product Branch 0.17 ancient branch
Summary 0010347: Okawaru + exploding sling bullet = penance
Description as a worshipper of Okawaru, I ran out of regular sling bullets and I ended up accidentally shooting an exploding sling bullet that hit my ice beast on an adjacent cell to a wight.
I was not warned that the action could put me under penance.
I think a warning should be provided.
Cheers,
Rob
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0030345)
PleasingFungus (administrator)
2016-04-10 22:22

Should be fixed in e643d41, thanks!
(0030362)
RoGGa (reporter)
2016-04-11 22:40

Great!

I did notice though a bizarre scenario while testing the changes under 0.18-a0-1745-gffa9a88

First of all, I copied over my saved file from v0.17.1 and then went into Wiz-mode.

When I target the cell next to a summoned allied ice beast, it warms me with the msg: "Really fire at your ally ice beast? This attack would place you under penance!"
If I press Y, it then states: "The explosion of sling bullet fragments engulfs your ice beast."
...but I am not under penance.

This action should definitely put me under penance because if I shoot a sling bullet directly at the same allied ice beast and the bullet misses it, I still go under penance since it stipulate in the religion screen for Okawaru's wrath:
"Okawaru strongly dislikes it when you attack allies."

Am I missing something?
(0030363)
PleasingFungus (administrator)
2016-04-12 00:03

Yeah, that's another bug. Pretty straightforward to reproduce, though (interestingly) only occurs for summoned allies - perma-allies (e.g. mercenaries) trigger penance correctly. Also interesting that the summoned ally isn't made hostile by the explosion.
(0030364)
PleasingFungus (administrator)
2016-04-12 00:04

IMO, file another ticket for it and mark this one related. I'm probably not going to fix it immediately.

- Issue History
Date Modified Username Field Change
2016-04-06 22:23 RoGGa New Issue
2016-04-10 22:22 PleasingFungus Note Added: 0030345
2016-04-10 22:22 PleasingFungus Status new => resolved
2016-04-10 22:22 PleasingFungus Fixed in Branch => 0.18 development branch
2016-04-10 22:22 PleasingFungus Resolution open => done
2016-04-10 22:22 PleasingFungus Assigned To => PleasingFungus
2016-04-11 22:40 RoGGa Note Added: 0030362
2016-04-12 00:03 PleasingFungus Note Added: 0030363
2016-04-12 00:04 PleasingFungus Note Added: 0030364
2016-12-17 18:36 RoGGa Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker