Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0010345 [DCSS] Bug Report minor have not tried 2016-04-06 08:26 2016-04-22 21:46
Reporter Undo View Status public  
Assigned To amalloy
Priority normal Resolution done  
Status resolved   Product Branch 0.18 ancient branch
Summary 0010345: !Curemut failed to work
Description I have two stages of permanent Teleportitis, and some assorted temporary muts from a demonspawn corruptor. I am playing a demonspawn. I just quaffed two !curemut potions and they failed to do anything (I also did get the new message reminding me that it wouldn't work on temporary mutations).

I believe I did manage to cure some other mutations I had, under the same temporary mutations, a little while previously (had to search for some curemuts for these remaining stages of teleportitis).
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0030324)
Undo (reporter)
2016-04-06 08:27

Oops, and the save file is
http://crawl.akrasiac.org/saves/Undo-crawl-git-9b5a2163f8-160406-0214.tar.bz2 [^]
(0030391)
amalloy (developer)
2016-04-22 21:46

Fixed in https://github.com/crawl/crawl/commit/6250cb24540717f171e1ad56787a1a5aa964b03c [^]

It turns out you were just getting unlucky: !cmut was randomly selecting your transient muts to cure, and then failing to cure them. I've changed it to just ignore transient muts, so it only "aims at" permanent muts.

Thanks for the report!

- Issue History
Date Modified Username Field Change
2016-04-06 08:26 Undo New Issue
2016-04-06 08:27 Undo Note Added: 0030324
2016-04-22 21:46 amalloy Note Added: 0030391
2016-04-22 21:46 amalloy Status new => resolved
2016-04-22 21:46 amalloy Fixed in Branch => 0.18 development branch
2016-04-22 21:46 amalloy Resolution open => done
2016-04-22 21:46 amalloy Assigned To => amalloy


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker