Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0010339 [DCSS] Bug Report trivial have not tried 2016-04-02 13:03 2016-04-05 01:36
Reporter RoGGa View Status public  
Assigned To MarvinPA
Priority normal Resolution done  
Status closed   Product Branch 0.17 ancient branch
Summary 0010339: Tree & Conf & Reach (with V-key) = "You're too confused to attack without stumbling around"
Description The scenario identified below is only an observation and is not a necessarily a bug.

As an Octopode OpIE, I quaffed a Potion of Lignification while I was already CONFused.
With a Trident in hand, I tried to reach (using the V-key) at the shadow of Sigmund (who had gone invisible) and was also 2 cells away (1 empty cell between him and I).

When I hit the V key to reach with a Trident in hand, I get the message "You're too confused to attack without stumbling around".

I'm assuming this is a general message that doesn't take in consideration that I'm in Tree-form .
I didn't expect being able to use the Reach command with a Trident in hand while CONFused but I gave it a try just in case it could work.

IMO, when CONFused, I don't think I should be allowed to drink a specific potion since it is already not possible to cast a spell.
Or to change weapons to a specific one for that matter.

Suggestion:
make quaffing potions, casting a spell, and switching weapons possible but pick a random one from any of the ones is inventory.

btw, there might also be other items that could be considered (such as equipment) if the above suggestion is implemented.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0030318)
MarvinPA (developer)
2016-04-02 13:43

Fixed to just use the standard "You're too confused!" message, thanks for reporting.

- Issue History
Date Modified Username Field Change
2016-04-02 13:03 RoGGa New Issue
2016-04-02 13:43 MarvinPA Note Added: 0030318
2016-04-02 13:43 MarvinPA Status new => resolved
2016-04-02 13:43 MarvinPA Fixed in Branch => 0.18 development branch
2016-04-02 13:43 MarvinPA Resolution open => done
2016-04-02 13:43 MarvinPA Assigned To => MarvinPA
2016-04-05 01:35 RoGGa Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker