Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0010332 [DCSS] Upload: Maps and Vaults minor N/A 2016-03-24 21:44 2018-10-24 01:30
Reporter Skrybe View Status public  
Assigned To Claws
Priority normal Resolution done  
Status closed   Product Branch 0.18 ancient branch
Summary 0010332: Two Crypt vaults
Description I was recently surprised to find that deep troll shamans will buff undead trolls just like living ones. I liked the idea of a deep troll "necromancer," and put together a couple of vaults to show off the interaction. These are tagged uniq_necro_troll, since both showing up in the same game might seem a little gimmicky. Feedback is welcome.
Additional Information
Tags No tags attached.
Attached Files ? file icon necro_troll.des [^] (1,150 bytes) 2016-03-24 21:44 [Show Content]
? file icon necro_troll_v2.des [^] (1,054 bytes) 2016-03-31 05:34 [Show Content]

- Relationships

-  Notes
(0030307)
Claws (developer)
2016-03-25 00:31

Clever.

With a depths adjustment, I think these would work better as downstairs and/or mild loot vaults than ambushes: as nasty as it is to be mobbed by hasted zombie trolls, the fact that zombies can't use stairs means it's very easy to separate the shaman from the others if one can survive the ascent.

Style stuff: For the second vault, you should use a KMONS: 23 = and different floor definitions rather than use the same monster definition twice. For the first vault, you should avoid splitting a basic monster definition across two lines (i.e. make a newline for the deep troll simulacrum) and use a SHUFFLE rather than a lua coinflip for the derived undead sets.

(Lua, however, might be useful for (you.depth() == dgn.br_depth(you.branch())) checks if you do that downstairs / loot arrangement to make the last floor of Crypt not try to place a downstairs.)
(0030308)
Skrybe (reporter)
2016-03-25 01:51

What would you recommend in terms of loot? I'm always wary of adding loot to vaults, b/c it's very easy to add too much.

I can imagine the first vault working better as a downstairs than the second. It might be possible to make a mad dash for the stairs in the first vault if a path was cleared through some of the trolls. That's less likely to work in the second vault, due to the water, though I'm fine with making the second one pure loot.
(0030317)
Skrybe (reporter)
2016-03-31 05:34

Uploading a modified version. The vault with no water is now a downstairs, the one with water now has 3 star items and no stairs. Too much/too little loot? Both now have doors, since from my limited testing, it didn't take much noise to lure the undead trolls away from the shaman. I fixed the headers, and made some minor layout changes.
(0030354)
Claws (developer)
2016-04-11 01:41

Added in d2ae9817e79d33, thanks!

Added you in CREDITS.txt as Skrybe, is that okay or would you prefer something else?
(0030365)
Skrybe (reporter)
2016-04-12 00:35

I'd prefer to be credited as Brent Adams. Thanks!

- Issue History
Date Modified Username Field Change
2016-03-24 21:44 Skrybe New Issue
2016-03-24 21:44 Skrybe File Added: necro_troll.des
2016-03-25 00:31 Claws Note Added: 0030307
2016-03-25 01:51 Skrybe Note Added: 0030308
2016-03-31 05:34 Skrybe Note Added: 0030317
2016-03-31 05:34 Skrybe File Added: necro_troll_v2.des
2016-04-11 01:41 Claws Note Added: 0030354
2016-04-11 01:41 Claws Status new => resolved
2016-04-11 01:41 Claws Fixed in Branch => 0.18 development branch
2016-04-11 01:41 Claws Resolution open => done
2016-04-11 01:41 Claws Assigned To => Claws
2016-04-12 00:35 Skrybe Note Added: 0030365
2018-10-24 01:30 Skrybe Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker