Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0010327 [DCSS] Bug Report major always 2016-03-20 09:21 2016-04-11 01:47
Reporter Lavandula View Status public  
Assigned To PleasingFungus
Priority normal Resolution done  
Status resolved   Product Branch 0.18 ancient branch
Summary 0010327: Demonspawn ignite blood mutation doesn't destroy puddles of blood
Description If floor tile has blood on it, it's impossible to make a monster to bleed on it again and set it on fire again. It's a bit annoying, because one has to seek ways to lure monster into clean tiles to make use of this mutation.
In the same vein, imaginary gore created by flayed ghosts burns. It dissappears normally, but flames don't.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0030356)
PleasingFungus (administrator)
2016-04-11 01:47
edited on: 2016-04-11 01:50

The first problem is fixed in 63d7f55; the second is, imho, not really worth fixing. (In terms of code complexity vs value - it would involve adding a fourth parameter to blood_spray() and a seventh (!) to bleed_onto_floor() and _maybe_bloodify_square().)


- Issue History
Date Modified Username Field Change
2016-03-20 09:21 Lavandula New Issue
2016-04-11 01:47 PleasingFungus Note Added: 0030356
2016-04-11 01:47 PleasingFungus Status new => resolved
2016-04-11 01:47 PleasingFungus Fixed in Branch => 0.18 development branch
2016-04-11 01:47 PleasingFungus Resolution open => done
2016-04-11 01:47 PleasingFungus Assigned To => PleasingFungus
2016-04-11 01:50 PleasingFungus Note Edited: 0030356


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker