Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0010285 [DCSS] Implementables minor N/A 2016-02-16 02:26 2016-11-12 00:02
Reporter wheals View Status public  
Assigned To PleasingFungus
Priority normal Resolution done  
Status resolved   Product Branch longterm development (0.25+)
Summary 0010285: Converting passive god abilities to use the new infrastructure
Description Rather than manually checking in multiple places for whether you have the right god/piety, passive abilities can use the
have_passive
abstraction. For each new passive, there needs to be a new entry in the
passive_t
enum in godpassive.h, and an entry in the god_passives structure. See https://github.com/crawl/crawl/commit/47dbdd306702 [^] for a good example of how to do this.
Additional Information
Tags simple
Attached Files

- Relationships

-  Notes
(0030480)
wheals (administrator)
2016-05-15 08:05
edited on: 2016-05-15 08:05

This is a pretty simple task. Note that there's no urgency in converting every god passive, so a patch with just a few changed over would be fine.

(0031209)
Brannock (developer)
2016-11-04 22:35

Implemented by bgiannan in https://github.com/crawl/crawl/commit/27cbb4196e4b [^] and https://github.com/crawl/crawl/commit/40744a825186 [^]

Unsure if there's more left to do, so not closing yet.
(0031226)
PleasingFungus (administrator)
2016-11-12 00:02

I'm closing this, since I don't like vague open-ended bugs.

- Issue History
Date Modified Username Field Change
2016-02-16 02:26 wheals New Issue
2016-05-15 08:04 wheals Tag Attached: simple
2016-05-15 08:05 wheals Note Added: 0030480
2016-05-15 08:05 wheals Note Edited: 0030480
2016-11-04 22:35 Brannock Note Added: 0031209
2016-11-12 00:02 PleasingFungus Note Added: 0031226
2016-11-12 00:02 PleasingFungus Status new => resolved
2016-11-12 00:02 PleasingFungus Fixed in Branch => 0.20 development branch
2016-11-12 00:02 PleasingFungus Resolution open => done
2016-11-12 00:02 PleasingFungus Assigned To => PleasingFungus


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker