Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0010278 [DCSS] Bug Report major always 2016-02-09 14:20 2017-12-31 09:26
Reporter Nikita View Status public  
Assigned To gammafunk
Priority normal Resolution done  
Status resolved   Product Branch 0.17 ancient branch
Summary 0010278: Mouse hover lags
Description I have some lags when moving cursor. Selected tile changes with a delay up to 2-3 seconds. There wasn't this problem in a previous versions.
My OS: Lubuntu 14.04
I have last version of Nvidia proprietary drivers.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0031351)
mrob (reporter)
2016-12-17 19:34

I had the same problem on Debian unstable, with free software AMD drivers. I bisected it to commit 9e6f58dcabc7f47398c9806e4c80f93efbd0d4d2: "Fix resizing of the Tiles window". This reverts cleanly on trunk, and doing so fixes the problem with no obvious side effects.
(0031424)
gammafunk (administrator)
2017-01-19 11:02

I finally spent some time to fully track this down, and was able to replicate it more easily to hopefully fix in 0.20-a0-502-g555d78b. If you can give this version a try, would be much appreciated. Works fine on my Ubuntu system after this fix and I confirmed with another user that it fixes the issue for them as well. Resolving, but do reopen if this doesn't fix the problem for you.
(0031427)
mrob (reporter)
2017-01-20 11:48

Works for me too. Thanks for fixing this!
(0031688)
Nikita (reporter)
2017-06-19 14:07

Thank you for such great work.
I have tested this issue on latest version of DCSS and found that all works fine except mage casts and ranged attacks. If you choose any spell and try to hover on enemy cursor will move over tiles one by one with delay.
Best regards.
(0032009)
aidanholm (developer)
2017-12-31 09:26

Thanks for reporting; this one was fixed at https://github.com/crawl/crawl/commit/50ea28b629dc [^]

- Issue History
Date Modified Username Field Change
2016-02-09 14:20 Nikita New Issue
2016-12-17 19:34 mrob Note Added: 0031351
2017-01-19 10:34 gammafunk Note Added: 0031423
2017-01-19 11:01 gammafunk Note Deleted: 0031423
2017-01-19 11:02 gammafunk Note Added: 0031424
2017-01-19 11:02 gammafunk Status new => resolved
2017-01-19 11:02 gammafunk Fixed in Branch => 0.20 development branch
2017-01-19 11:02 gammafunk Resolution open => done
2017-01-19 11:02 gammafunk Assigned To => gammafunk
2017-01-20 11:48 mrob Note Added: 0031427
2017-06-19 14:07 Nikita Note Added: 0031688
2017-06-19 14:07 Nikita Status resolved => new
2017-06-19 14:07 Nikita Resolution done => reopened
2017-08-11 10:20 johnnyzero Issue Monitored: johnnyzero
2017-12-31 09:26 aidanholm Note Added: 0032009
2017-12-31 09:26 aidanholm Status new => resolved
2017-12-31 09:26 aidanholm Resolution reopened => done


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker