Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0010264 [DCSS] Bug Report minor always 2016-01-30 15:28 2016-02-25 03:44
Reporter Kvaak View Status public  
Assigned To PleasingFungus
Priority normal Resolution done  
Status resolved   Product Branch 0.18 ancient branch
Summary 0010264: Iron giants waste turns failing to throw
Description 1: They attempt to throw you even if there's no space to do so. As the spellcasting message is squelched this manifests as the giant skipping a turn for no apparent reason. To reproduce dig a zigzaggy killhole:

#.###
##.##
#C###
##@##
#####

2: The description of the throw is outdated (iron giants don't constrict you)

3: The throw ignores EV, if this is intentional the effect should probably be reflavored.

I also find it odd it's made of iron but also natural and living. And since iron conducts electricity the fact it packs rF and rC but no rElec kind of sticks out.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0030179)
MarvinPA (developer)
2016-01-30 16:15

Fixed the spell description. The resistances and being living seem totally fine to me, consistent with iron dragons.
(0030212)
PleasingFungus (administrator)
2016-02-25 03:44
edited on: 2016-02-25 03:44

(1) fixed in ba84f3e. The remaining questions are pretty subjective flavor things and probably don't need a tracking bug.


- Issue History
Date Modified Username Field Change
2016-01-30 15:28 Kvaak New Issue
2016-01-30 16:15 MarvinPA Note Added: 0030179
2016-01-30 16:24 MarvinPA Summary Iron giant quirkiness => Iron giants waste turns failing to throw
2016-02-25 03:44 PleasingFungus Note Added: 0030212
2016-02-25 03:44 PleasingFungus Status new => resolved
2016-02-25 03:44 PleasingFungus Fixed in Branch => 0.18 development branch
2016-02-25 03:44 PleasingFungus Resolution open => done
2016-02-25 03:44 PleasingFungus Assigned To => PleasingFungus
2016-02-25 03:44 PleasingFungus Note Edited: 0030212


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker