Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0010219 [DCSS] Bug Report crash always 2016-01-02 13:46 2016-01-02 23:54
Reporter zeiran View Status public  
Assigned To wheals
Priority normal Resolution done  
Status resolved   Product Branch 0.17 ancient branch
Summary 0010219: Crash when trying to burn trees near map border
Description When I repeatedly cast Bolt of Fire on the trees near map border game crashes with following messages.

ASSERT(!cell_is_solid(ctarget)) in 'cloud.cc' at line 755 failed.

ASSERT(!cell_is_solid(ctarget)) in 'cloud.cc' at line 755 failed.

We crashed! This is likely due to a bug in Crawl. Please submit a bug report at https://crawl.develz.org/mantis/ [^] and include the crash report (/home/zeiran/.crawl/morgue/crash-Nogograe-20160102-152649.txt), your save file (/home/zeiran/.crawl/saves/Nogograe.cs), and a description of what you were doing when this crash occurred.

Aborted
Additional Information
Tags No tags attached.
Attached Files txt file icon crash-Nogograe-20160102-153927.txt [^] (44,615 bytes) 2016-01-02 13:46 [Show Content]
txt file icon crash-Nogograe-20160102-153733.txt [^] (44,740 bytes) 2016-01-02 13:46 [Show Content]
txt file icon crash-Nogograe-20160102-152649.txt [^] (44,029 bytes) 2016-01-02 13:46 [Show Content]
? file icon Nogograe.cs [^] (654,070 bytes) 2016-01-02 13:47

- Relationships

-  Notes
(0030104)
PleasingFungus (administrator)
2016-01-02 19:22

I'm not able to reproduce this in my own testing (on 0.17 local tiles), for whatever that's worth.
(0030106)
wheals (administrator)
2016-01-02 23:54

Fixed in trunk (https://github.com/crawl/crawl/commit/20bfd954c1f). [^]

- Issue History
Date Modified Username Field Change
2016-01-02 13:46 zeiran New Issue
2016-01-02 13:46 zeiran File Added: crash-Nogograe-20160102-153927.txt
2016-01-02 13:46 zeiran File Added: crash-Nogograe-20160102-153733.txt
2016-01-02 13:46 zeiran File Added: crash-Nogograe-20160102-152649.txt
2016-01-02 13:47 zeiran File Added: Nogograe.cs
2016-01-02 19:22 PleasingFungus Note Added: 0030104
2016-01-02 23:54 wheals Note Added: 0030106
2016-01-02 23:54 wheals Status new => resolved
2016-01-02 23:54 wheals Fixed in Branch => 0.18 development branch
2016-01-02 23:54 wheals Resolution open => done
2016-01-02 23:54 wheals Assigned To => wheals


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker