Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0010165 [DCSS] Bug Report crash have not tried 2015-12-12 17:47 2015-12-12 23:59
Reporter Teryn View Status public  
Assigned To neil
Priority normal Resolution done  
Status resolved   Product Branch 0.17 ancient branch
Summary 0010165: segfault on spellcast attempt
Description I tried to cast Dazzling Spray with my Spriggan, but before it could activate, the game segfaulted and crashed cleanly to console. Nothing else indicated any instability, though I did upgrade Arch Linux's stone-soup package before resuming this saved game. Crash report and saved game are attached.

Additional Information
Tags No tags attached.
Attached Files ? file icon Iled.cs [^] (1,012,003 bytes) 2015-12-12 17:47
txt file icon crash-Iled-20151212-110714.txt [^] (50,346 bytes) 2015-12-12 17:48 [Show Content]
txt file icon crash-Iled-20151212-121240.txt [^] (48,482 bytes) 2015-12-12 18:54 [Show Content]
? file icon Iled02.cs [^] (1,012,003 bytes) 2015-12-12 18:56

- Relationships

-  Notes
(0029959)
Teryn (reporter)
2015-12-12 18:52
edited on: 2015-12-12 18:57

UPDATE: Bug *is* reproducable; another segfault when just trying to aim Dazzling Spray.

New crash file and save added. Also, possibly relevant for Arch Linux package builds of stone-soup: https://www.archlinux.org/news/c-abi-change/ [^]

Second crash's save file is appended with an "02".

(0029965)
neil (administrator)
2015-12-12 23:59

This particular crash should be fixed in 0.17.1-1-g73c8601. We'll probably do another release soon to get the fix out.

(there are other crashes with dazzling spray, because of ray rounding, but those only happen at particular coordinates on the map, not whenever the targetter aims into a wall)

- Issue History
Date Modified Username Field Change
2015-12-12 17:47 Teryn New Issue
2015-12-12 17:47 Teryn File Added: Iled.cs
2015-12-12 17:48 Teryn File Added: crash-Iled-20151212-110714.txt
2015-12-12 17:51 Teryn Issue Monitored: Teryn
2015-12-12 18:52 Teryn Note Added: 0029959
2015-12-12 18:54 Teryn File Added: crash-Iled-20151212-121240.txt
2015-12-12 18:56 Teryn File Added: Iled02.cs
2015-12-12 18:57 Teryn Note Edited: 0029959
2015-12-12 23:59 neil Note Added: 0029965
2015-12-12 23:59 neil Status new => resolved
2015-12-12 23:59 neil Fixed in Branch => 0.17 stable branch
2015-12-12 23:59 neil Resolution open => done
2015-12-12 23:59 neil Assigned To => neil
2016-01-10 21:38 Teryn Issue End Monitor: Teryn
2016-01-10 21:38 Teryn Issue Monitored: Teryn


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker