Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0010163 [DCSS] Bug Report trivial always 2015-12-11 21:42 2015-12-12 22:30
Reporter crate View Status public  
Assigned To neil
Priority normal Resolution done  
Status closed   Product Branch 0.18 ancient branch
Summary 0010163: Backgrounds start with food in slot "e" even though crawl otherwise tries to avoid this.
Description As the summary says. Many characters start with a ration in slot "e" (e.g. hufi with a weapon). Crawl will avoid placing picked-up food in slot "e" if there are any other slots open. This is inconsistent, and the pickup behaviour is better since it exists to avoid accidental "ee" eating, so the starting equipment should follow the same rules.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0029961)
neil (administrator)
2015-12-12 20:47

Fixed in trunk (0.18-a0-757-g15d63d9), thanks!

- Issue History
Date Modified Username Field Change
2015-12-11 21:42 crate New Issue
2015-12-12 20:47 neil Note Added: 0029961
2015-12-12 20:47 neil Status new => resolved
2015-12-12 20:47 neil Fixed in Branch => 0.18 development branch
2015-12-12 20:47 neil Resolution open => done
2015-12-12 20:47 neil Assigned To => neil
2015-12-12 22:30 crate Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker