Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0010119 [DCSS] Bug Report crash always 2015-11-28 23:49 2015-11-29 00:54
Reporter pedritolo View Status public  
Assigned To Medar
Priority normal Resolution done  
Status resolved   Product Branch 0.17 ancient branch
Summary 0010119: wizmode crash after using &@ (set stats) with stat loss
Description save file attached, just cast shatter to reproduce the bug

edit: title was: crash to desktop after casting "shatter"
Additional Information
Tags No tags attached.
Attached Files 7z file icon saves - cast shatter to crash to desktop.7z [^] (1,254,645 bytes) 2015-11-28 23:49
? file icon Qikekhag.cs [^] (84,634 bytes) 2015-11-29 00:20

- Relationships

-  Notes
(0029889)
Medar (developer)
2015-11-29 00:53
edited on: 2015-11-29 00:55

Fixed in 0.18-a0-352-g8bd5ab4.

Crash is caused by using &@ (set stats) in wizmode when you have stat loss, it actually happens when gaining certain amount of XP after that.

The only way to make this save not crash is losing some stats before gaining more XP (as far as I can see anyway).

Thanks for the report!


- Issue History
Date Modified Username Field Change
2015-11-28 23:49 pedritolo New Issue
2015-11-28 23:49 pedritolo File Added: saves - cast shatter to crash to desktop.7z
2015-11-29 00:20 Medar File Added: Qikekhag.cs
2015-11-29 00:53 Medar Note Added: 0029889
2015-11-29 00:53 Medar Status new => resolved
2015-11-29 00:53 Medar Fixed in Branch => 0.18 development branch
2015-11-29 00:53 Medar Resolution open => done
2015-11-29 00:53 Medar Assigned To => Medar
2015-11-29 00:54 Medar Summary crash to desktop after casting "shatter" => wizmode crash after using &@ (set stats) with stat loss
2015-11-29 00:54 Medar Description Updated
2015-11-29 00:55 Medar Note Edited: 0029889


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker