Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0010101 [DCSS] Bug Report minor always 2015-11-26 03:41 2016-04-12 01:52
Reporter elliptic View Status public  
Assigned To PleasingFungus
Priority normal Resolution done  
Status resolved   Product Branch 0.18 ancient branch
Summary 0010101: Vault warden sealing stairs while leaving V confuses ctrl-O
Description If a warden uses its sealing ability while you are exiting V:1 via the gate to D, then ctrl-O will forget that you have entered V and won't even know where the entrance is. Interlevel travel to V will also be broken. Re-entering V manually then fixes some of these issues, though ctrl-O still doesn't know what level the V entrance is on.

Credit should be given to qw for finding this bug.
Additional Information
Tags No tags attached.
Attached Files png file icon Ctrl-O.png [^] (36,424 bytes) 2016-04-12 01:27


png file icon Ctrl-G.png [^] (135,981 bytes) 2016-04-12 01:28

- Relationships
related to 0009855closedPleasingFungus Crypt doesn't appear in the Dungeon overview 
has duplicate 0007621resolvedPleasingFungus Branch stairs sealing and dungeon overview screen. 
related to 0010025new in Vaults, CTRL-G gives default to D:1 

-  Notes
(0030273)
PleasingFungus (administrator)
2016-03-01 17:07

I *believe* this is fixed by e1ff36ed4774.
(0030366)
RoGGa (reporter)
2016-04-12 01:27
edited on: 2016-04-12 01:49

It doesn't seem to be fixed in: 0.18-a0-1745-gffa9a88
when testing with Wiz-mode (see attachment Ctrl-O.png )

Also, it does seem like the issue is related to issue ID 0010025
see attachment Ctrl-G.png
(the 2 attached screenshots were taken at the same time in the game).

Fyi, I sent myself directly from D:1 to Vault:1 using &~V1

(0030367)
RoGGa (reporter)
2016-04-12 01:52

The error didn't occur in another game where I:
- used Wiz-mode,
- went to D:13 using the command: &~D13
and then finding the Vault entrance
before sending myself in the Vault using &~V1

Hope this helps in narrowing it down

- Issue History
Date Modified Username Field Change
2015-11-26 03:41 elliptic New Issue
2015-11-26 10:40 Medar Relationship added related to 0010025
2016-02-29 22:19 PleasingFungus Relationship added related to 0009855
2016-03-01 17:07 PleasingFungus Note Added: 0030273
2016-03-01 17:07 PleasingFungus Status new => resolved
2016-03-01 17:07 PleasingFungus Fixed in Branch => 0.18 development branch
2016-03-01 17:07 PleasingFungus Resolution open => done
2016-03-01 17:07 PleasingFungus Assigned To => PleasingFungus
2016-04-12 01:27 RoGGa File Added: Ctrl-O.png
2016-04-12 01:27 RoGGa Note Added: 0030366
2016-04-12 01:28 RoGGa File Added: Ctrl-G.png
2016-04-12 01:49 RoGGa Note Edited: 0030366
2016-04-12 01:52 RoGGa Note Added: 0030367
2016-07-05 06:16 PleasingFungus Relationship added has duplicate 0007621


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker