Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0010080 [DCSS] Bug Report minor have not tried 2015-11-15 09:12 2019-02-27 04:38
Reporter rchandra View Status public  
Assigned To sgrunt
Priority normal Resolution done  
Status resolved   Product Branch 0.17 ancient branch
Summary 0010080: Lua error in shoals:$ (shoals_end_grunt_garden / shoals_ilsuiw_ice)
Description On entering shoals:4:

Lua error running hook 'post_place' on map 'shoals_end_grunt_garden':
 /crawl-master/crawl-0.17/data/dat/dlua/dungeon.lua:583: Failed to place map
 'shoals_ilsuiw_ice'

!lm rchandra ogen br.end=shoals 1 -tv
Additional Information
Tags No tags attached.
Attached Files

- Relationships
related to 0010262resolvedadvil lua error placing shoals_ilsuiw_ice 

-  Notes
(0029800)
rchandra (reporter)
2015-11-15 16:25

Ilsuiw did appear, not in an obvious vault but with Qazlal noise and plantmangling I can't be sure.
(0029801)
sgrunt (administrator)
2015-11-15 16:48

Theory: this is being caused by the end vault placer being a minivault, not a primary vault, allowing another vault to place on the level before the end vault does and taking up enough space that subvaults can't place. I've seen this in testing and had assumed then that it was because I had another PLACE: Shoals:$ primary vault.

Solution: make the Shoals:$ end placers primary vaults? We need to do this anyway if we ever want non-distributed endings.
(0029802)
sgrunt (administrator)
2015-11-15 17:09

I made the above change in 0.18-a0-115-g8c10bc3, to be backported after the tournament ends as it might have a significant balance impact.
(0030157)
advil (administrator)
2016-01-23 00:36

Just got this in current 0.17 (on cbro), guess it didn't get backported yet.

- Issue History
Date Modified Username Field Change
2015-11-15 09:12 rchandra New Issue
2015-11-15 16:25 rchandra Note Added: 0029800
2015-11-15 16:48 sgrunt Note Added: 0029801
2015-11-15 17:09 sgrunt Note Added: 0029802
2015-11-15 17:09 sgrunt Assigned To => sgrunt
2015-11-15 17:09 sgrunt Status new => resolved
2015-11-15 17:09 sgrunt Resolution open => done
2015-11-15 17:09 sgrunt Fixed in Branch => 0.18 development branch
2016-01-23 00:36 advil Note Added: 0030157
2019-02-27 04:38 advil Relationship added related to 0010262


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker