Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0010053 [DCSS] Patches minor always 2015-11-07 03:15 2015-11-25 22:42
Reporter geekosaur View Status public  
Assigned To wheals
Priority normal Resolution done  
Status closed   Product Branch 0.18 ancient branch
Summary 0010053: modern clang doesn't use -O4 to mean -flto
Description Apparently that behavior was in LLVM before 5.1 (not sure what version of clang that represents but probably clang 2.x and maybe very early 3; clang 3.4 doesn't have it). I've been patching locally to use -O2 -flto like gcc builds.

Patch attached. I don't attempt to determine by clang version number since I don't know when it changed; this may affect clang builds on platforms with older clang (I notice the gentoo wiki still talks about -O4, for example).
Additional Information
Tags No tags attached.
Attached Files ? file icon lto.patch [^] (668 bytes) 2015-11-07 03:15 [Show Content]

- Relationships

-  Notes
(0029837)
wheals (administrator)
2015-11-25 21:33

Added a simplified version in https://github.com/crawl/crawl/commit/1425b752a89e [^] (hope it works...)

- Issue History
Date Modified Username Field Change
2015-11-07 03:15 geekosaur New Issue
2015-11-07 03:15 geekosaur File Added: lto.patch
2015-11-25 21:33 wheals Note Added: 0029837
2015-11-25 21:33 wheals Status new => resolved
2015-11-25 21:33 wheals Fixed in Branch => 0.18 development branch
2015-11-25 21:33 wheals Resolution open => done
2015-11-25 21:33 wheals Assigned To => wheals
2015-11-25 22:42 geekosaur Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker