Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0010040 [DCSS] Bug Report minor always 2015-10-31 20:38 2015-11-01 03:27
Reporter nicolae View Status public  
Assigned To wheals
Priority normal Resolution done  
Status resolved   Product Branch 0.18 ancient branch
Summary 0010040: Corpses and chunks can't appear in shops, and will cause a crash if they are the only inventory options.
Description Corpses and chunks can't appear in shops, even if they are specified in the vault definition for that shop. A shop defined as:

KFEAT: S = food shop type:Dead suffix:Meat ; human corpse w:50 | human chunk w:50 | meat ration w:1

will generate only a bunch of meat rations.

If the game tries to place a shop that contains only corpses and chunks, then the game will crash. This can happen if there is a vault containing a specially-defined carrion-only shop, but it can also happen if a ghoul of Gozag tries to use Call Merchant to place a food shop. (Apparently this is either a recent bug or there haven't been many starving ghouls of Gozag.)
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0029700)
MarvinPA (developer)
2015-10-31 20:43

No time to look into it more at the moment but see place_monster_corpse in mon-death.cc:

<+MarvinPA> it looks like corpse shops are broken because of the check to prevent placing monsters in walls
<+MarvinPA> in which case i don't know how it ever worked but yeah
<+MarvinPA> er, to prevent placing corpses in walls rather
<+PleasingFungus> oh
<+PleasingFungus> the way that items were placed in shops was changed
<+PleasingFungus> by wheals, I think
<+MarvinPA> it's checking the location of the dummy monster that's used to define the corpse though
(0029708)
wheals (administrator)
2015-11-01 03:27

Fixed in 0.18-a0-17-g8f701cd, and also 0.17 because of the Gh^Gozag case.

- Issue History
Date Modified Username Field Change
2015-10-31 20:38 nicolae New Issue
2015-10-31 20:43 MarvinPA Note Added: 0029700
2015-11-01 03:27 wheals Note Added: 0029708
2015-11-01 03:27 wheals Status new => resolved
2015-11-01 03:27 wheals Fixed in Branch => 0.17 prerelease branch
2015-11-01 03:27 wheals Resolution open => done
2015-11-01 03:27 wheals Assigned To => wheals


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker