Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0010038 [DCSS] Bug Report minor have not tried 2015-10-31 03:01 2015-11-01 03:06
Reporter Bamboomancer View Status public  
Assigned To wheals
Priority normal Resolution done  
Status resolved   Product Branch 0.18 ancient branch
Summary 0010038: Snaplasher Vine Segments Become Permanent after falling through a shaft
Description I summoned a forest in Snake, and after it went away, I had permanent Snaplasher Vines, some of which were red for some reason. After looking through the log, it appears one of the segments fell through a shaft:

_You hear a splash. x2
_You start resting.
_Your snaplasher vine falls limply to the ground.
 Your snaplasher vine falls through a shaft!
_The shaft crumbles and collapses.

Included is a screenshot of the game at the time of the bug.
Additional Information
Tags No tags attached.
Attached Files jpg file icon BamboomancerBug.jpg [^] (348,889 bytes) 2015-10-31 03:01
? file icon 10038.patch [^] (953 bytes) 2015-10-31 18:00 [Show Content]

- Relationships

-  Notes
(0029691)
ebering (developer)
2015-10-31 18:02

Attached patch should fix the issue, though I had some trouble replicating because getting a tentacle to shaft itself is ugh.

A better man would add a wizmode xv command to shaft a target monster but that man is not me.
(0029707)
wheals (administrator)
2015-11-01 03:06

Added to 0.17 and 0.18.

Life hack: stone of tremors.

- Issue History
Date Modified Username Field Change
2015-10-31 03:01 Bamboomancer New Issue
2015-10-31 03:01 Bamboomancer File Added: BamboomancerBug.jpg
2015-10-31 18:00 ebering File Added: 10038.patch
2015-10-31 18:02 ebering Note Added: 0029691
2015-11-01 03:06 wheals Note Added: 0029707
2015-11-01 03:06 wheals Status new => resolved
2015-11-01 03:06 wheals Fixed in Branch => 0.17 prerelease branch
2015-11-01 03:06 wheals Resolution open => done
2015-11-01 03:06 wheals Assigned To => wheals


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker