Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0010000 [DCSS] Bug Report minor have not tried 2015-10-08 06:25 2016-01-14 04:21
Reporter WildSam View Status public  
Assigned To wheals
Priority normal Resolution done  
Status resolved   Product Branch 0.17 ancient branch
Summary 0010000: Porkation removes items on mercenaries.
Description Played on CXC webtiles actually, but there is no such option.

After Kirke porked me and my merfolk impaler friend and died, aformentioned friend reverted back to his glorious impaling form.
But all his items were lost in process (trident of venom and glowing robe). Not just dropped (which is already tragedy given removal of item-related orders), but totally disappeared.
Transformations meld items only temporary for players and as some folks said at #crawl for monsters it's same. Anyway it makes Kirke quite ruining for any permanent summons (impaler without impaling tools!) and probably a bug.

Here: Nesuk the merfolk impaler (friendly, durably summoned)
instead of screenshot
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0029935)
neil (administrator)
2015-12-05 18:26

0.18-a0-666-gdb01d97 addresses this for Beogh followers (they lose the "already gifted an item" flag), but doesn't do anything for mercenaries (who come with items but can't be gifted new ones). And it only partially fixes Beogh followers, since you can only gift them one item but they probably dropped two or three (weapon, armour, shield).
(0030133)
wheals (administrator)
2016-01-14 04:21

https://github.com/crawl/crawl/commit/c3146ca5e886 [^] will fix this (for the future).

- Issue History
Date Modified Username Field Change
2015-10-08 06:25 WildSam New Issue
2015-12-05 18:26 neil Note Added: 0029935
2016-01-14 04:21 wheals Note Added: 0030133
2016-01-14 04:21 wheals Status new => resolved
2016-01-14 04:21 wheals Fixed in Branch => 0.18 development branch
2016-01-14 04:21 wheals Resolution open => done
2016-01-14 04:21 wheals Assigned To => wheals


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker