Viewing Issue Advanced Details Jump to Notes ] Wiki ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0009929 [DCSS] Bug Report minor have not tried 2015-08-31 00:25 2015-09-06 02:14
Reporter Sprucery View Status public  
Assigned To neil
Priority normal Resolution done Local or Remote Local
Status closed   Operating System MacOSX
Projection none   Console or Tiles Tiles
ETA none Fixed in Branch 0.17 ancient branch Product Branch 0.16 ancient branch
  Product Version
Summary 0009929: Shadow mimic does not target ranged attacks properly
Description If I aim a ranged attack (in my case a sling shot) at an enemy and there's and ally behind said enemy, my shadow mimic's ranged attack may miss the enemy and hit the ally thereby making it hostile. Of course my own ranged attack was targeted to stop at the enemy. The shadow mimic does not copy the targeting exactly.

I'm not sure if this is intended or a bug.
Steps To Reproduce
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0029443)
neil (administrator)
2015-08-31 01:36

Fixed in trunk (0.17-a0-1739-g7adb240), thanks! Was already fixed for spells a while ago, see 0009614.

- Issue History
Date Modified Username Field Change
2015-08-31 00:25 Sprucery New Issue
2015-08-31 01:36 neil Note Added: 0029443
2015-08-31 01:36 neil Status new => resolved
2015-08-31 01:36 neil Fixed in Branch => 0.17 development branch
2015-08-31 01:36 neil Resolution open => done
2015-08-31 01:36 neil Assigned To => neil
2015-09-06 02:14 Sprucery Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker