Viewing Issue Advanced Details Jump to Notes ] Wiki ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0009686 [DCSS] Bug Report feature always 2015-04-27 03:13 2018-01-30 17:07
Reporter tedric View Status public  
Assigned To wheals
Priority normal Resolution done Local or Remote Both
Status resolved   Operating System All
Projection none   Console or Tiles Both
ETA none Fixed in Branch 0.22 old branch Product Branch 0.17 ancient branch
  Product Version
Summary 0009686: Display spell failure % for "dangerous to cast" warning
Description The warning "This spell is dangerous to cast!" would be more useful if it included the current spell failure percentage. As is, I often have to escape out of the prompt and check the spell menu manually to see if I'm willing to risk it.
Steps To Reproduce
Additional Information
Tags simple
Attached Files ? file icon spl-cast.cc [^] (70,275 bytes) 2016-11-14 14:22

- Relationships

-  Notes
(0028981)
Sandman25 (reporter)
2015-04-27 04:48

The chance would not be that useful (Animate Skeleton at 80% failure rate is fine, Fire Storm at 80% failure rate is not).
The message is different depending on fail severity (colour of miscast):
    "slightly dangerous",
    "quite dangerous",
    "very dangerous".
See options_guide also:
fail_severity_to_confirm = 3
        Ask for confirmation when attempting to cast a spell where a miscast
        would cause severe penalties. Prompt if the miscast severity of the
        spell (the colour shown in the spellcasting menu) is greater than
        or equal to the number specified:

          3: dark red
          2: light red or higher
          1: yellow or higher
(0028982)
tedric (reporter)
2015-04-27 04:58

Sandman, this change only matters for spells where miscasts are harmful enough to prompt a warning even when the failure rate is relatively low. You don't get warnings for low-level spells even when they are guaranteed to fail, and this is appropriate because attempting to cast them anyway carries basically no risk. But you DO get warnings for mid-level spells (like say Fireball) when the failure rate is already down around 20% -- which is a risk I'm willing to take in some situations. I would like the interface to provide the readily available info that I need to make that decision in a smoother manner.
(0028983)
Sandman25 (reporter)
2015-04-27 05:31
edited on: 2015-04-27 05:32

Tedric, you are right, displaying the chance can be useful. My current character had DMsl yellow both with and without ring of wizardry, it was optimal to switch to the ring before casting of course.

(0031256)
Zenthirum (reporter)
2016-11-14 14:28

Hello, I modified the file spl-cast.cc to implement this. The prompt now says
"The spell is very dangerous to cast (100% risk of failure)! Continue anyway?".
Compiles and runs without problem for me using gcc on linux.

I'm not sure about the correct procedure to submit patches, I attached the modified file to this bug, apologies if that's the wrong way to do it!
(0031820)
johnstein (reporter)
2017-09-08 08:46

I started working this one at: https://github.com/crawl/crawl/pull/610 [^]

Zenthirum, I started with your update, then added a couple more things:

1. Display the fail percentage for the basic 'z' command that shows your last selected spell

2. Add some exclamation points in proportion to the fail severity (since I didn't think colors was the correct approach. you can do z? if you want to see the pretty colors)
(0032074)
wheals (administrator)
2018-01-30 17:07

Done in https://github.com/crawl/crawl/commit/89a73045dd18df5b6406da78bebf277d5030efc5 [^]

- Issue History
Date Modified Username Field Change
2015-04-27 03:13 tedric New Issue
2015-04-27 04:48 Sandman25 Note Added: 0028981
2015-04-27 04:58 tedric Note Added: 0028982
2015-04-27 05:31 Sandman25 Note Added: 0028983
2015-04-27 05:32 Sandman25 Note Edited: 0028983
2016-08-19 20:42 PleasingFungus Tag Attached: simple
2016-11-14 14:22 Zenthirum File Added: spl-cast.cc
2016-11-14 14:23 Zenthirum Issue Monitored: Zenthirum
2016-11-14 14:28 Zenthirum Note Added: 0031256
2017-09-08 08:46 johnstein Note Added: 0031820
2018-01-30 17:07 wheals Note Added: 0032074
2018-01-30 17:07 wheals Status new => resolved
2018-01-30 17:07 wheals Fixed in Branch => 0.22 development branch
2018-01-30 17:07 wheals Resolution open => done
2018-01-30 17:07 wheals Assigned To => wheals


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker