Viewing Issue Advanced Details Jump to Notes ] Wiki ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0009416 [DCSS] Patches feature N/A 2015-01-18 21:27 2015-04-14 07:13
Reporter Kvaak View Status public  
Assigned To PleasingFungus
Priority normal Resolution not fixable Local or Remote Both
Status resolved   Operating System All
Projection none   Console or Tiles Both
ETA none Fixed in Branch 0.16 ancient branch Product Branch experimental branch
  Product Version 0.16-a0-3667-g690a316
Summary 0009416: Minor Bearkin tweaks.
Description #1 Gives Bearkin deformed body as originally intended.
0000002 Bumps up a bunch of Bearkin apts, mostly to make the armour apt less comical and improve bear wizards.
Steps To Reproduce
Additional Information
Tags No tags attached.
Attached Files ? file icon 0001-Deform-Bearkin-s-body-as-originally-intended.patch [^] (716 bytes) 2015-01-18 21:27 [Show Content]
? file icon 0001-Bump-Bearkin-apts-up-slightly.patch [^] (2,792 bytes) 2015-01-18 21:28 [Show Content]
? file icon 0001-Clean-up-lower-stat-gain-to-sane-levels.patch [^] (2,267 bytes) 2015-01-18 22:47 [Show Content]
? file icon 0001-Make-Bearkin-bearsome-from-the-start.patch [^] (17,260 bytes) 2015-01-19 20:10 [Show Content]
? file icon 0001-Make-bears-less-insane-at-XL1.patch [^] (2,480 bytes) 2015-01-19 22:02 [Show Content]

- Relationships

-  Notes
(0028304)
Kvaak (reporter)
2015-01-18 22:48

Because tiny minipatches are fun here's one that gives bears not-batshit-insane statgain.
(0028310)
Kvaak (reporter)
2015-01-19 20:14

Drastic rework, couldn't find a way to salvage the old concept. Now you start as a bear(kin). They might be kind of overpowered now though, depends how their offence-defence balance works out.
(0028311)
Kvaak (reporter)
2015-01-19 22:04

Dropped the crazy mad XL1 muts, as bears now start with +3 HP they can afford to get the clawing/biting stuff as they level, retaining some of the original flavor.
(0028412)
8Escape (reporter)
2015-01-31 22:10
edited on: 2015-01-31 22:11

Bearkin currently have a +2 aptitude for translocations. Not sure if this is intentional or not given that warper is not a recommended class for them and that translocations appears twice in the aps document.

(0028841)
PleasingFungus (administrator)
2015-04-14 07:13

Patches don't apply on the branch & much of this will probably need rewriting now that wheals redid species code. Feel free to reopen this or open a new ticket, as suits you.

- Issue History
Date Modified Username Field Change
2015-01-18 21:27 Kvaak New Issue
2015-01-18 21:27 Kvaak File Added: 0001-Deform-Bearkin-s-body-as-originally-intended.patch
2015-01-18 21:28 Kvaak File Added: 0001-Bump-Bearkin-apts-up-slightly.patch
2015-01-18 22:47 Kvaak File Added: 0001-Clean-up-lower-stat-gain-to-sane-levels.patch
2015-01-18 22:48 Kvaak Note Added: 0028304
2015-01-19 20:10 Kvaak File Added: 0001-Make-Bearkin-bearsome-from-the-start.patch
2015-01-19 20:14 Kvaak Note Added: 0028310
2015-01-19 22:02 Kvaak File Added: 0001-Make-bears-less-insane-at-XL1.patch
2015-01-19 22:04 Kvaak Note Added: 0028311
2015-01-31 22:10 8Escape Note Added: 0028412
2015-01-31 22:11 8Escape Note Edited: 0028412
2015-04-14 07:13 PleasingFungus Note Added: 0028841
2015-04-14 07:13 PleasingFungus Status new => resolved
2015-04-14 07:13 PleasingFungus Fixed in Branch => 0.16 pre-release branch
2015-04-14 07:13 PleasingFungus Resolution open => not fixable
2015-04-14 07:13 PleasingFungus Assigned To => PleasingFungus


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker