Viewing Issue Advanced Details Jump to Notes ] Wiki ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0009155 [DCSS] Bug Report minor have not tried 2014-11-08 06:06 2015-01-06 16:18
Reporter Kyrris View Status public  
Assigned To wheals
Priority normal Resolution done Local or Remote Remote
Status closed   Operating System CSZO
Projection none   Console or Tiles Console
ETA none Fixed in Branch 0.16 ancient branch Product Branch 0.16 ancient branch
  Product Version 0.16-a0-1970-g0967df0
Summary 0009155: Shadow mimic kills don't trigger mummy death curses
Description  Your shadow mimicks your spell!
 The shadow shard hits the mummy.
_The mummy is destroyed!
_Magic restored.


From ^p screen. Note lack of ill effect.
Steps To Reproduce
Additional Information
Tags No tags attached.
Attached Files ? file icon 0001-Trigger-mummies-etc.-on-Dith-shadow-spell-kills.patch [^] (2,249 bytes) 2015-01-05 23:50 [Show Content]

- Relationships

-  Notes
(0027692)
wheals (administrator)
2014-11-09 00:40

This will probably be pretty hard to fix without untangling the mess that is monster_die(); assigned to myself as a reminder to look into it when doing so.
(0028238)
neil (administrator)
2015-01-05 23:50

The problem here is that the beam's agent() is you but the killer is KILL_MON_MISSILE. This is because the shadow mimic uses MID_PLAYER instead of having its own mid: it worked back when beams stored mindex instead of mid.

The attached patch fixes this, BUT I am not sure whether anything relies on actor_to_death_source returning NON_MONSTER instead of MHITYOU when the player is the source.
(0028240)
neil (administrator)
2015-01-06 00:53

Apparently NON_MONSTER there was unintentional.
(0028241)
neil (administrator)
2015-01-06 00:56

Fixed in trunk (0.16-a0-3502-g7dfabb2), thanks!

- Issue History
Date Modified Username Field Change
2014-11-08 06:06 Kyrris New Issue
2014-11-09 00:39 wheals Status new => assigned
2014-11-09 00:39 wheals Assigned To => wheals
2014-11-09 00:40 wheals Note Added: 0027692
2015-01-05 23:50 neil Note Added: 0028238
2015-01-05 23:50 neil File Added: 0001-Trigger-mummies-etc.-on-Dith-shadow-spell-kills.patch
2015-01-06 00:53 neil Note Added: 0028240
2015-01-06 00:56 neil Note Added: 0028241
2015-01-06 00:56 neil Status assigned => resolved
2015-01-06 00:56 neil Fixed in Branch => 0.16 development branch
2015-01-06 00:56 neil Resolution open => done
2015-01-06 16:18 Kyrris Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker