Viewing Issue Advanced Details Jump to Notes ] Wiki ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0008746 [DCSS] Bug Report crash always 2014-06-29 05:22 2014-06-30 04:34
Reporter godzilla View Status public  
Assigned To neil
Priority normal Resolution done Local or Remote Local
Status resolved   Operating System Linux
Projection none   Console or Tiles Tiles
ETA none Fixed in Branch 0.15 ancient branch Product Branch 0.15 ancient branch
  Product Version 0.15-a0-1788-ga796aff
Summary 0008746: Crash on entering Swamp
Description Any time I enter Swamp with any character crawl crashes, giving the message "ASSERT(idx >= TILE_WALL_MAX && idx < TILE_FEAT_MAX) int 'rltiles/tiledef-feat.cc' at line 2602 failed."
It continued to crash, giving the same message, every time I attempted to load the save. I tried this in wizard mode with 3 different characters and got the same thing. Attached is the save with which I initially noticed the issue. I'm using version 0.15-a0-1788-ga796aff on Linux using tiles. I tried rebuilding crawl but that didn't fix it.
Steps To Reproduce
Additional Information
Tags No tags attached.
Attached Files txt file icon crash-snare-20140628-185306.txt [^] (49,037 bytes) 2014-06-29 05:22 [Show Content]
? file icon snare.cs [^] (826,755 bytes) 2014-06-29 09:17

- Relationships

-  Notes
(0026650)
PleasingFungus (administrator)
2014-06-29 07:23

You attached a crashlog, not a save. You're in (something)/morgue; you need to go to (something)/saves. Your game should be in there.
(0026651)
godzilla (reporter)
2014-06-29 09:20

Sorry about that. I thought the log would be more helpful because this was happening with multiple characters. Anyway, it's uploaded now.
(0026653)
neil (administrator)
2014-06-30 04:34

Fixed in trunk (0.15-a0-1804-ga2c5d24), thanks!

- Issue History
Date Modified Username Field Change
2014-06-29 05:22 godzilla New Issue
2014-06-29 05:22 godzilla File Added: crash-snare-20140628-185306.txt
2014-06-29 07:23 PleasingFungus Note Added: 0026650
2014-06-29 09:17 godzilla File Added: snare.cs
2014-06-29 09:20 godzilla Note Added: 0026651
2014-06-30 04:34 neil Note Added: 0026653
2014-06-30 04:34 neil Status new => resolved
2014-06-30 04:34 neil Fixed in Branch => 0.15 development branch
2014-06-30 04:34 neil Resolution open => done
2014-06-30 04:34 neil Assigned To => neil


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker