Viewing Issue Advanced Details Jump to Notes ] Wiki ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0008571 [DCSS] Patches minor N/A 2014-05-18 17:06 2014-06-23 05:40
Reporter PleasingFungus View Status public  
Assigned To PleasingFungus
Priority normal Resolution done Local or Remote Both
Status resolved   Operating System All
Projection none   Console or Tiles Both
ETA none Fixed in Branch 0.15 ancient branch Product Branch 0.15 ancient branch
  Product Version
Summary 0008571: Ghost fixes
Description Two patches - one to fix an existing crash when reading 0-byte ghostfiles (restoring what seems to have been the expected behavior), and one to again add support for multiple ghost files per level.
Steps To Reproduce
Additional Information
Tags No tags attached.
Attached Files ? file icon 0001-Don-t-die-when-encountering-0-byte-ghost-files.patch [^] (4,953 bytes) 2014-05-18 17:06 [Show Content]
? file icon 0001-New-attempt-at-multi-ghost-file-support.patch [^] (8,285 bytes) 2014-05-18 17:07 [Show Content]

- Relationships

-  Notes
(0026199)
PleasingFungus (administrator)
2014-05-18 17:09

A small amount of tweaking may be required to get these patches to play nicely together. (Since both touch load_ghost().)
(0026601)
PleasingFungus (administrator)
2014-06-23 05:40

These were fixed some time ago.

- Issue History
Date Modified Username Field Change
2014-05-18 17:06 PleasingFungus New Issue
2014-05-18 17:06 PleasingFungus File Added: 0001-Don-t-die-when-encountering-0-byte-ghost-files.patch
2014-05-18 17:07 PleasingFungus Issue Monitored: PleasingFungus
2014-05-18 17:07 PleasingFungus Issue End Monitor: PleasingFungus
2014-05-18 17:07 PleasingFungus File Added: 0001-New-attempt-at-multi-ghost-file-support.patch
2014-05-18 17:09 PleasingFungus Note Added: 0026199
2014-05-19 14:05 neil Status new => assigned
2014-05-19 14:05 neil Assigned To => neil
2014-06-06 21:26 neil Assigned To neil => PleasingFungus
2014-06-23 05:40 PleasingFungus Note Added: 0026601
2014-06-23 05:40 PleasingFungus Status assigned => resolved
2014-06-23 05:40 PleasingFungus Fixed in Branch => 0.15 development branch
2014-06-23 05:40 PleasingFungus Resolution open => done


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker