Viewing Issue Advanced Details Jump to Notes ] Wiki ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0008476 [DCSS] Patches minor have not tried 2014-04-30 08:51 2014-12-21 09:03
Reporter chris View Status public  
Assigned To PleasingFungus
Priority normal Resolution done Local or Remote Local
Status closed   Operating System Other
Projection none   Console or Tiles Both
ETA none Fixed in Branch 0.15 ancient branch Product Branch 0.15 ancient branch
  Product Version
Summary 0008476: Weapon enchantment merger — [1] slaying rings/artefacts [2] weapons
Description Weapon enchantment merger — Combine wpn.plus and wpn.plus2 to one single enchantment. [1] for slaying rings and +Acc/+Dam artefact properties
[2] for weapons

[1]
===
Simplify some code now that slaying only uses item.plus
No longer consider Dam+ boring on artefacts
Ruin Fencer's Gloves (and adapt the other randarts)
Combine plus/plus2 for rings of slaying, and Acc+/Dam+ on artefacts

Patchset: https://github.com/ChrisOelmueller/crawl-ref/compare/master...slayring.patch [^]

Browse in superior interface: https://github.com/ChrisOelmueller/crawl-ref/compare/master...slayring [^]

Known issues: Slaying rings should probably cap out at +6 (also when upgrading saves).

[2]
===
Combine all three enchant weapon scrolls
Plus2: l_item and attempt at trove fixup
Plus2: Remove from ng-setup (and readability) (REVIEW)
Plus2: Upgrade old weapons
Plus2: (JEWEL/WPN) Simplify
Plus2: Trog/Oka and some other stuff
Plus2: Sprints
Plus2: Update unrand weapons (todo demon axe and 27)
Remove two more references to missile enchantment

Patchset: https://github.com/ChrisOelmueller/crawl-ref/compare/slayring...weapons.patch [^]

Browse in superior interface: https://github.com/ChrisOelmueller/crawl-ref/compare/slayring...weapons [^]

Known issues: Trove code presumably is broken both for new and upgrading games (i.e. has not been tested). Commit messages are not worded for a submission, some commits could be polished. Scroll balance needs to be looked at (for the ?ew changes in here, but also for ?id and ?rc from other recent changes).

Due to the way past patches have been handled by the devteam, I will not maintain these submissions. That boils down to:
Feel free to use whatever you'd like to, edit and expand on the other stuff, reject and discard the rest. I am unable to fix the remaining issues myself.

I apologize for the second section of this set in particular, I'd normally not have submitted it in this state, but I feel that this change is an important one and hope someone will pick it up where I left off.
Steps To Reproduce
Additional Information
Tags No tags attached.
Attached Files ? file icon 0001-Hide-old-enchant-weapon-scrolls-in-autopickup-menu.patch [^] (1,955 bytes) 2014-06-15 17:27 [Show Content]

- Relationships

-  Notes
(0026489)
PleasingFungus (administrator)
2014-06-14 08:53

Rebased & pushed [1].
(0026508)
PleasingFungus (administrator)
2014-06-15 08:00

Rebased and pushed [2].
(0026516)
chris (updater)
2014-06-15 17:28

Thanks (especially for fixing up the broken bits). A small tweak for the \ menu is attached.
(0026517)
PleasingFungus (administrator)
2014-06-15 18:06

Tested & pushed. Thanks!

- Issue History
Date Modified Username Field Change
2014-04-30 08:51 chris New Issue
2014-06-14 08:53 PleasingFungus Note Added: 0026489
2014-06-15 08:00 PleasingFungus Note Added: 0026508
2014-06-15 08:00 PleasingFungus Status new => resolved
2014-06-15 08:00 PleasingFungus Fixed in Branch => 0.15 development branch
2014-06-15 08:00 PleasingFungus Resolution open => done
2014-06-15 08:00 PleasingFungus Assigned To => PleasingFungus
2014-06-15 17:27 chris File Added: 0001-Hide-old-enchant-weapon-scrolls-in-autopickup-menu.patch
2014-06-15 17:28 chris Note Added: 0026516
2014-06-15 18:06 PleasingFungus Note Added: 0026517
2014-12-21 09:03 chris Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker