Viewing Issue Advanced Details Jump to Notes ] Wiki ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007741 [DCSS] Bug Report major have not tried 2013-11-13 02:37 2013-11-14 02:54
Reporter G-Flex View Status public  
Assigned To KiloByte
Priority normal Resolution done Local or Remote Remote
Status resolved   Operating System CSZO
Projection none   Console or Tiles Console
ETA none Fixed in Branch 0.14 ancient branch Product Branch 0.14 ancient branch
  Product Version 0.14-a0-836-g5210f43
Summary 0007741: Vaults branch does not exist in game after dungeon-split merge
Description I started this game prior to the introduction of the "Depths" lower-dungeon replacement.

From the in-game log:
----------
50168 | Lair:2 | Upgraded the game from 0.14-a0-806-g7df33cc to
                  | 0.14-a0-832-g11d3004
----------
This marks the spot where I transitioned the save from pre-Depths to post-Depths. It's worth noting that at this point, I had already been as deep as D:17 (at least), and so had already gone through the runelock.

I had not been to D:27 yet, but as of the backed-up save (linked below), I have been, just to see if Zot exists. I magic mapped the level and found three portals, and |amethyst confirmed for me that one of them is Zot.

And yes, I've fully explored all of D below D:14 (except for D:27), and found all three stairs on each (although only one down stair is on D:14, there are three up stairs on D:15).

I've also explored all of Spider and Swamp, Orc, Lair, the Temple, and partially explored Slime 1-2. I haven't explored Elf, Vaults (obviously), Crypt, Forest, Tomb, Zot, Hells, or Pan, and haven't been sent to the Abyss.

Link to save: https://dobrazupa.org/saves/swinepaste-crawl-git-5210f43197-131113-0122.tar.bz2 [^]
Steps To Reproduce
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0024393)
neil (administrator)
2013-11-13 02:42

The Vaults entrance was supposed to be on D:20, but G-Flex had not yet visited D:20 before transferring the save to post-split. The Depths entrance was generated on D:27 (D:$) after the transfer, but it was a mimic (intentionally, I think, the same as Lair branch entrances on the wrong level). D:27 did have a portal to zot without an entry vault.
(0024394)
neil (administrator)
2013-11-13 02:49

I edited G-Flex's save to add the Vaults portal on D:20 where it was supposed to be.
(0024396)
G-Flex (reporter)
2013-11-13 04:19

It's worth noting that when I went into Vaults (with the fixed save; see above notes), Crypt and Blade appeared as they should have, and autoexplore seems to be working okay. Crypt and Blade are also listed correctly on the ^g and ^o menus. It was only showing Crypt before I found it (and not Forest as well), but that seems to be due to another bug.
(0024400)
KiloByte (manager)
2013-11-13 08:50

In my tests before pushing the split, it went ok, but it turned out I missed the case when a vault failed to place. Grunt has already fixed this in 0.14-a0-836-g5210f43, all that's left is how to fix affected games.

And a minor issue of Vaults showing at D:5 on ^o.
(0024402)
KiloByte (manager)
2013-11-13 15:00

Added a shim to fix old saves.
(0024407)
G-Flex (reporter)
2013-11-14 02:54

Hrm. What about hell/pan/abyss portals? I've fully explored all of D and have found a bunch of Pandemonium portals but none to Abyss or Hell. This makes Abyss theoretically accessible (through pan or banishment/distortion unwielding), but not Hell.

- Issue History
Date Modified Username Field Change
2013-11-13 02:37 G-Flex New Issue
2013-11-13 02:42 neil Note Added: 0024393
2013-11-13 02:49 neil Note Added: 0024394
2013-11-13 04:19 G-Flex Note Added: 0024396
2013-11-13 08:50 KiloByte Note Added: 0024400
2013-11-13 15:00 KiloByte Note Added: 0024402
2013-11-13 15:00 KiloByte Status new => resolved
2013-11-13 15:00 KiloByte Fixed in Branch => 0.14 development branch
2013-11-13 15:00 KiloByte Resolution open => done
2013-11-13 15:00 KiloByte Assigned To => KiloByte
2013-11-14 02:54 G-Flex Note Added: 0024407


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker