Viewing Issue Advanced Details Jump to Notes ] Wiki ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007593 [DCSS] Bug Report crash sometimes 2013-10-02 20:26 2014-01-16 09:00
Reporter KiloByte View Status public  
Assigned To neil
Priority normal Resolution done Local or Remote
Status resolved   Operating System
Projection none   Console or Tiles
ETA none Fixed in Branch 0.16 ancient branch Product Branch 0.13 ancient branch
  Product Version
Summary 0007593: map generation uses player's traversability
Description Some versions, including 0.14-a0-101-gdd5ec2a on armhf, crash during the des cache build. Even with no apparently related changes, this crash seems to vary wildly with Crawl's build and architecture -- but seemingly not the RNG's state.

The culprit turns out to be pathfind using RMODE_EXPLORE even for map generation. Most vaults get test-built once during the cache build, ie, those which don't typically include this code:
    if is_validating() then return; end

Player traversability depends on permaflight, permaflight checks suppression, which in turn touches something not yet uninitialized.

Obviously, disabling all validation would paper over this crash but we still don't want to depend on whether the player can swim/lavaswim/permafly.
Steps To Reproduce
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0024138)
neil (administrator)
2013-10-03 01:51

Fixed in trunk (0.14-a0-116-g3b2d4cb and 0.14-a0-117-gc4feb4a, with a related fix in 0.14-a0-118-g5e1fb2d). These might need more testing before being picked into 0.13

- Issue History
Date Modified Username Field Change
2013-10-02 20:26 KiloByte New Issue
2013-10-03 01:51 neil Note Added: 0024138
2013-10-03 01:51 neil Status new => resolved
2013-10-03 01:51 neil Fixed in Branch => longterm development (0.14+)
2013-10-03 01:51 neil Resolution open => done
2013-10-03 01:51 neil Assigned To => neil
2014-01-16 09:00 user3976 Note Added: 0025005
2014-01-16 09:00 user3976 Note Deleted: 0025005


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker